aboutsummaryrefslogtreecommitdiffstats
path: root/app/unisono/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniil Cherednik <dan.cherednik@gmail.com>2023-12-12 23:17:35 +0100
committerDaniil Cherednik <dan.cherednik@gmail.com>2023-12-12 23:17:35 +0100
commit0f08bc5487adffde5f3e0aff30ffe41b53a21bf1 (patch)
treedce92f6daa256f17d8e292e1578605af2f2218f9 /app/unisono/CMakeLists.txt
parent93a9691246574b6d51ddbbdb5be3dceb89ff24e9 (diff)
downloadlibfshift-main.tar.gz
Draft implementation:HEADmain
- f must be divisors of 44100 and be positive - 44100 hardcoded
Diffstat (limited to 'app/unisono/CMakeLists.txt')
-rw-r--r--app/unisono/CMakeLists.txt13
1 files changed, 12 insertions, 1 deletions
diff --git a/app/unisono/CMakeLists.txt b/app/unisono/CMakeLists.txt
index 8a44354..67bf8e0 100644
--- a/app/unisono/CMakeLists.txt
+++ b/app/unisono/CMakeLists.txt
@@ -22,7 +22,18 @@ find_library(LIBSNDFILE_LIBRARY
message(STATUS "sndfile include dirs path: ${LIBSNDFILE_INCLUDE_DIR}")
message(STATUS "sndfile libs path: ${LIBSNDFILE_LIBRARY}")
+if(LIBFSHIFT_BUILD_PUB_HEADER)
+ message(STATUS "use libfshift include path: ${LIBFSHIFT_BUILD_PUB_HEADER}")
+ include_directories(${LIBFSHIFT_BUILD_PUB_HEADER})
+endif()
+
add_executable(unisono "main.c")
+
+if(LIBFSHIFT_BUILD_LIB_PATH)
+ message(STATUS "use libfshift lib path: ${LIBFSHIFT_BUILD_LIB_PATH}")
+ target_link_libraries(unisono PRIVATE ${LIBFSHIFT_BUILD_LIB_PATH})
+endif()
+
include_directories(${LIBSNDFILE_INCLUDE_DIRS})
-target_link_libraries(unisono PRIVATE ${LIBSNDFILE_LIBRARY})
+target_link_libraries(unisono PRIVATE ${LIBSNDFILE_LIBRARY} m)