aboutsummaryrefslogtreecommitdiffstats
path: root/app/unisono/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniil Cherednik <dan.cherednik@gmail.com>2023-12-06 21:30:14 +0100
committerDaniil Cherednik <dan.cherednik@gmail.com>2023-12-06 21:30:14 +0100
commit93a9691246574b6d51ddbbdb5be3dceb89ff24e9 (patch)
tree3f6611ae8d22b496644fa6b863d2a9597b5d4e8b /app/unisono/CMakeLists.txt
parentcf80678d0c2472092be2da141247f61de292aafb (diff)
downloadlibfshift-93a9691246574b6d51ddbbdb5be3dceb89ff24e9.tar.gz
Just simple tool to show the library usage.
Diffstat (limited to 'app/unisono/CMakeLists.txt')
-rw-r--r--app/unisono/CMakeLists.txt28
1 files changed, 28 insertions, 0 deletions
diff --git a/app/unisono/CMakeLists.txt b/app/unisono/CMakeLists.txt
new file mode 100644
index 0000000..8a44354
--- /dev/null
+++ b/app/unisono/CMakeLists.txt
@@ -0,0 +1,28 @@
+cmake_minimum_required(VERSION 3.12)
+
+project(unisono)
+set (CMAKE_C_STANDARD 99)
+set (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -g -fsanitize=address -fno-omit-frame-pointer")
+
+find_package(PkgConfig QUIET)
+if(PKG_CONFIG_FOUND)
+ pkg_check_modules(LIBSNDFILE_PKGCONF sndfile)
+endif(PKG_CONFIG_FOUND)
+
+find_path(LIBSNDFILE_INCLUDE_DIR
+ NAMES sndfile.h
+ PATHS ${LIBSNDFILE_PKGCONF_INCLUDE_DIRS}
+)
+
+find_library(LIBSNDFILE_LIBRARY
+ NAMES sndfile libsndfile-1
+ PATHS ${LIBSNDFILE_PKGCONF_LIBRARY_DIRS}
+)
+
+message(STATUS "sndfile include dirs path: ${LIBSNDFILE_INCLUDE_DIR}")
+message(STATUS "sndfile libs path: ${LIBSNDFILE_LIBRARY}")
+
+add_executable(unisono "main.c")
+include_directories(${LIBSNDFILE_INCLUDE_DIRS})
+target_link_libraries(unisono PRIVATE ${LIBSNDFILE_LIBRARY})
+