aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniil Cherednik <dan.cherednik@gmail.com>2024-07-31 22:07:21 +0000
committerDaniil Cherednik <dan.cherednik@gmail.com>2024-07-31 22:07:21 +0000
commit61c74a7dab606653ae82153786031b6a0260ec16 (patch)
tree8663519b21a95f3e7821b53832d2199b6698da74 /CMakeLists.txt
parentf1c9056c40e22b6aea21da5281e469b93a334778 (diff)
downloadatracdenc-61c74a7dab606653ae82153786031b6a0260ec16.tar.gz
[AT3P] Add GHA related bitstream code
* borrow Huffman table from FFmpeg * code (with ut) to pack frequency part of GHA block * some related data structures * bitstrem modification to write correct GHA block * switch compile flag to use float data type
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0332f19..02a31dc 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -3,7 +3,7 @@ CMAKE_MINIMUM_REQUIRED(VERSION 3.1)
project(atracdenc)
include_directories(src)
-option(ATDE_USE_FLOAT "use float32 precision for dsp" OFF)
+set(ATDE_USE_FLOAT ON)
if (UNIX)
find_package(GTest)