aboutsummaryrefslogtreecommitdiffstats
path: root/contrib/libs/poco/Foundation/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/libs/poco/Foundation/CMakeLists.txt')
-rw-r--r--contrib/libs/poco/Foundation/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/contrib/libs/poco/Foundation/CMakeLists.txt b/contrib/libs/poco/Foundation/CMakeLists.txt
index d90657116d..a692f90f36 100644
--- a/contrib/libs/poco/Foundation/CMakeLists.txt
+++ b/contrib/libs/poco/Foundation/CMakeLists.txt
@@ -6,12 +6,12 @@
# original buildsystem will not be accepted.
-if (CMAKE_SYSTEM_PROCESSOR STREQUAL "aarch64" AND UNIX AND NOT APPLE AND NOT ANDROID)
+if (CMAKE_SYSTEM_NAME STREQUAL "Linux" AND CMAKE_SYSTEM_PROCESSOR STREQUAL "aarch64")
include(CMakeLists.linux-aarch64.txt)
-elseif (APPLE AND CMAKE_SYSTEM_PROCESSOR STREQUAL "x86_64")
+elseif (CMAKE_SYSTEM_NAME STREQUAL "Darwin" AND CMAKE_SYSTEM_PROCESSOR STREQUAL "x86_64")
include(CMakeLists.darwin-x86_64.txt)
elseif (WIN32 AND CMAKE_SYSTEM_PROCESSOR STREQUAL "AMD64" AND NOT HAVE_CUDA)
include(CMakeLists.windows-x86_64.txt)
-elseif (CMAKE_SYSTEM_PROCESSOR STREQUAL "x86_64" AND UNIX AND NOT APPLE AND NOT ANDROID AND NOT HAVE_CUDA)
+elseif (CMAKE_SYSTEM_NAME STREQUAL "Linux" AND CMAKE_SYSTEM_PROCESSOR STREQUAL "x86_64" AND NOT HAVE_CUDA)
include(CMakeLists.linux-x86_64.txt)
endif()