aboutsummaryrefslogtreecommitdiffstats
path: root/util/CMakeLists.txt
diff options
context:
space:
mode:
authorthegeorg <thegeorg@yandex-team.ru>2022-02-23 11:43:35 +0300
committerthegeorg <thegeorg@yandex-team.ru>2022-02-23 11:43:35 +0300
commitdc607d4bdea3e3fd300a1b96c14989024ae4370b (patch)
tree9bb9326da2ea21cab63ed845051b293ca5317420 /util/CMakeLists.txt
parent73db9ea237def2c2635db24388affcc401da6e3e (diff)
downloadydb-dc607d4bdea3e3fd300a1b96c14989024ae4370b.tar.gz
clang-cl: Enable yet another warning with the very long name
ref:878ef48a386627a1eb0325b0ccff820b1d627900
Diffstat (limited to 'util/CMakeLists.txt')
-rw-r--r--util/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/util/CMakeLists.txt b/util/CMakeLists.txt
index e61a0c6777..7dfb4b6db8 100644
--- a/util/CMakeLists.txt
+++ b/util/CMakeLists.txt
@@ -1,4 +1,7 @@
add_library(yutil)
+target_compile_options(yutil PRIVATE
+ -Wnarrowing
+)
target_link_libraries(yutil PUBLIC
contrib-libs-cxxsupp
util-charset