aboutsummaryrefslogtreecommitdiffstats
path: root/util/CMakeLists.txt
diff options
context:
space:
mode:
authordcherednik <dcherednik@ydb.tech>2022-10-26 16:40:35 +0300
committerdcherednik <dcherednik@ydb.tech>2022-10-26 16:40:35 +0300
commitb981cca279190176740c3bf5c5b4fd03be51b599 (patch)
treef5ec6210fdce0e976cbbe4dc8ae78bb6509adf49 /util/CMakeLists.txt
parent6dc0de995652f7eeecdbdb88dc98b00bb0653a2f (diff)
downloadydb-b981cca279190176740c3bf5c5b4fd03be51b599.tar.gz
Enable linux-arm platform.
Diffstat (limited to 'util/CMakeLists.txt')
-rw-r--r--util/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/util/CMakeLists.txt b/util/CMakeLists.txt
index 79468a5d8d..3e0811fb22 100644
--- a/util/CMakeLists.txt
+++ b/util/CMakeLists.txt
@@ -6,7 +6,9 @@
# original buildsystem will not be accepted.
-if (APPLE)
+if (CMAKE_SYSTEM_PROCESSOR STREQUAL "aarch64" AND UNIX AND NOT APPLE AND NOT ANDROID)
+ include(CMakeLists.linux-aarch64.txt)
+elseif (APPLE)
include(CMakeLists.darwin.txt)
elseif (CMAKE_SYSTEM_PROCESSOR STREQUAL "x86_64" AND UNIX AND NOT APPLE AND NOT ANDROID)
include(CMakeLists.linux.txt)