aboutsummaryrefslogtreecommitdiffstats
path: root/library/cpp/yson_pull/CMakeLists.txt
diff options
context:
space:
mode:
authorthegeorg <thegeorg@yandex-team.com>2022-12-15 19:25:15 +0300
committerthegeorg <thegeorg@yandex-team.com>2022-12-15 19:25:15 +0300
commit0c31d97afd7858af5f8f858c8addf91655ca9ccc (patch)
tree4d8a246db168f7beaafcd06d486c034115c2123d /library/cpp/yson_pull/CMakeLists.txt
parentd1d5f5e00df0dd6efc00880dd8283477fc643aaf (diff)
downloadydb-0c31d97afd7858af5f8f858c8addf91655ca9ccc.tar.gz
Sync linux-headers instead of using system ones
Diffstat (limited to 'library/cpp/yson_pull/CMakeLists.txt')
-rw-r--r--library/cpp/yson_pull/CMakeLists.txt35
1 files changed, 7 insertions, 28 deletions
diff --git a/library/cpp/yson_pull/CMakeLists.txt b/library/cpp/yson_pull/CMakeLists.txt
index 342f1532a8..3e0811fb22 100644
--- a/library/cpp/yson_pull/CMakeLists.txt
+++ b/library/cpp/yson_pull/CMakeLists.txt
@@ -6,31 +6,10 @@
# original buildsystem will not be accepted.
-
-add_library(yson_pull)
-target_link_libraries(yson_pull PUBLIC
- contrib-libs-cxxsupp
- yutil
- tools-enum_parser-enum_serialization_runtime
-)
-target_sources(yson_pull PRIVATE
- ${CMAKE_SOURCE_DIR}/library/cpp/yson_pull/consumer.cpp
- ${CMAKE_SOURCE_DIR}/library/cpp/yson_pull/event.cpp
- ${CMAKE_SOURCE_DIR}/library/cpp/yson_pull/exceptions.cpp
- ${CMAKE_SOURCE_DIR}/library/cpp/yson_pull/input.cpp
- ${CMAKE_SOURCE_DIR}/library/cpp/yson_pull/output.cpp
- ${CMAKE_SOURCE_DIR}/library/cpp/yson_pull/read_ops.cpp
- ${CMAKE_SOURCE_DIR}/library/cpp/yson_pull/reader.cpp
- ${CMAKE_SOURCE_DIR}/library/cpp/yson_pull/scalar.cpp
- ${CMAKE_SOURCE_DIR}/library/cpp/yson_pull/writer.cpp
-)
-generate_enum_serilization(yson_pull
- ${CMAKE_SOURCE_DIR}/library/cpp/yson_pull/event.h
- INCLUDE_HEADERS
- library/cpp/yson_pull/event.h
-)
-generate_enum_serilization(yson_pull
- ${CMAKE_SOURCE_DIR}/library/cpp/yson_pull/scalar.h
- INCLUDE_HEADERS
- library/cpp/yson_pull/scalar.h
-)
+if (CMAKE_SYSTEM_PROCESSOR STREQUAL "aarch64" AND UNIX AND NOT APPLE AND NOT ANDROID)
+ include(CMakeLists.linux-aarch64.txt)
+elseif (APPLE)
+ include(CMakeLists.darwin.txt)
+elseif (CMAKE_SYSTEM_PROCESSOR STREQUAL "x86_64" AND UNIX AND NOT APPLE AND NOT ANDROID)
+ include(CMakeLists.linux.txt)
+endif()