aboutsummaryrefslogtreecommitdiffstats
path: root/library/cpp/threading/local_executor/CMakeLists.txt
diff options
context:
space:
mode:
authorthegeorg <thegeorg@yandex-team.com>2022-12-15 19:25:15 +0300
committerthegeorg <thegeorg@yandex-team.com>2022-12-15 19:25:15 +0300
commit0c31d97afd7858af5f8f858c8addf91655ca9ccc (patch)
tree4d8a246db168f7beaafcd06d486c034115c2123d /library/cpp/threading/local_executor/CMakeLists.txt
parentd1d5f5e00df0dd6efc00880dd8283477fc643aaf (diff)
downloadydb-0c31d97afd7858af5f8f858c8addf91655ca9ccc.tar.gz
Sync linux-headers instead of using system ones
Diffstat (limited to 'library/cpp/threading/local_executor/CMakeLists.txt')
-rw-r--r--library/cpp/threading/local_executor/CMakeLists.txt20
1 files changed, 7 insertions, 13 deletions
diff --git a/library/cpp/threading/local_executor/CMakeLists.txt b/library/cpp/threading/local_executor/CMakeLists.txt
index 536ef537b0..3e0811fb22 100644
--- a/library/cpp/threading/local_executor/CMakeLists.txt
+++ b/library/cpp/threading/local_executor/CMakeLists.txt
@@ -6,16 +6,10 @@
# original buildsystem will not be accepted.
-
-add_library(cpp-threading-local_executor)
-target_link_libraries(cpp-threading-local_executor PUBLIC
- contrib-libs-cxxsupp
- yutil
- contrib-libs-tbb
- cpp-threading-future
- cpp-deprecated-atomic
-)
-target_sources(cpp-threading-local_executor PRIVATE
- ${CMAKE_SOURCE_DIR}/library/cpp/threading/local_executor/local_executor.cpp
- ${CMAKE_SOURCE_DIR}/library/cpp/threading/local_executor/tbb_local_executor.cpp
-)
+if (CMAKE_SYSTEM_PROCESSOR STREQUAL "aarch64" AND UNIX AND NOT APPLE AND NOT ANDROID)
+ include(CMakeLists.linux-aarch64.txt)
+elseif (APPLE)
+ include(CMakeLists.darwin.txt)
+elseif (CMAKE_SYSTEM_PROCESSOR STREQUAL "x86_64" AND UNIX AND NOT APPLE AND NOT ANDROID)
+ include(CMakeLists.linux.txt)
+endif()