aboutsummaryrefslogtreecommitdiffstats
path: root/library/cpp/charset/lite/CMakeLists.txt
diff options
context:
space:
mode:
authorshokhor <shokhor@yandex-team.com>2023-09-19 05:45:26 +0300
committershokhor <shokhor@yandex-team.com>2023-09-19 06:02:49 +0300
commitae87be2b19d1d4e6a5c7bad6650381690b5dfe9d (patch)
treee3dd23427bd7e3eda2785c33de59cf1ac9f07e1d /library/cpp/charset/lite/CMakeLists.txt
parent1df0281596525a87ffe350f2e94b91e10fa46bca (diff)
downloadydb-ae87be2b19d1d4e6a5c7bad6650381690b5dfe9d.tar.gz
Introduce library/cpp/charset/lite which excludes functionality with dependency on libiconv
Introduce library/cpp/charset/lite which excludes functionality with dependency on libiconv Задача: - выпилить зависимость от libiconv в библиотеке клавиатуры для андроид libiconv приходит из двух мест: - dict/dictutil - library/cpp/charset В обоих случаях libiconv используется в вариантах CharToWide/WideToChar для перекодировки. Первый кейс dictutil - клавиатура для релиза строится с ключом DICTUTIL_WITHOUT_ICONV_AND_UNICODE, который исключает зависимость. Следующий шаг сделать флаг по умолчанию для мобильных билдов. Второй кейс library/cpp/charset: 1. Шаг - выделяем библиотеку library/cpp/charset/lite без части функциональности, зависящей от libiconv (этот ПР) 2. Шаг - переводим библиотеки, используемые клавиатурой на lite версию (следующий ПР)
Diffstat (limited to 'library/cpp/charset/lite/CMakeLists.txt')
-rw-r--r--library/cpp/charset/lite/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/library/cpp/charset/lite/CMakeLists.txt b/library/cpp/charset/lite/CMakeLists.txt
new file mode 100644
index 0000000000..f8b31df0c1
--- /dev/null
+++ b/library/cpp/charset/lite/CMakeLists.txt
@@ -0,0 +1,17 @@
+
+# This file was generated by the build system used internally in the Yandex monorepo.
+# Only simple modifications are allowed (adding source-files to targets, adding simple properties
+# like target_include_directories). These modifications will be ported to original
+# ya.make files by maintainers. Any complex modifications which can't be ported back to the
+# original buildsystem will not be accepted.
+
+
+if (CMAKE_SYSTEM_NAME STREQUAL "Linux" AND CMAKE_SYSTEM_PROCESSOR STREQUAL "aarch64" AND NOT HAVE_CUDA)
+ include(CMakeLists.linux-aarch64.txt)
+elseif (CMAKE_SYSTEM_NAME STREQUAL "Darwin" AND CMAKE_SYSTEM_PROCESSOR STREQUAL "x86_64")
+ include(CMakeLists.darwin-x86_64.txt)
+elseif (WIN32 AND CMAKE_SYSTEM_PROCESSOR STREQUAL "AMD64" AND NOT HAVE_CUDA)
+ include(CMakeLists.windows-x86_64.txt)
+elseif (CMAKE_SYSTEM_NAME STREQUAL "Linux" AND CMAKE_SYSTEM_PROCESSOR STREQUAL "x86_64" AND NOT HAVE_CUDA)
+ include(CMakeLists.linux-x86_64.txt)
+endif()