aboutsummaryrefslogtreecommitdiffstats
path: root/library/cpp/blockcodecs/codecs/legacy_zstd06/CMakeLists.txt
diff options
context:
space:
mode:
authorthegeorg <thegeorg@yandex-team.com>2022-12-15 19:25:15 +0300
committerthegeorg <thegeorg@yandex-team.com>2022-12-15 19:25:15 +0300
commit0c31d97afd7858af5f8f858c8addf91655ca9ccc (patch)
tree4d8a246db168f7beaafcd06d486c034115c2123d /library/cpp/blockcodecs/codecs/legacy_zstd06/CMakeLists.txt
parentd1d5f5e00df0dd6efc00880dd8283477fc643aaf (diff)
downloadydb-0c31d97afd7858af5f8f858c8addf91655ca9ccc.tar.gz
Sync linux-headers instead of using system ones
Diffstat (limited to 'library/cpp/blockcodecs/codecs/legacy_zstd06/CMakeLists.txt')
-rw-r--r--library/cpp/blockcodecs/codecs/legacy_zstd06/CMakeLists.txt26
1 files changed, 7 insertions, 19 deletions
diff --git a/library/cpp/blockcodecs/codecs/legacy_zstd06/CMakeLists.txt b/library/cpp/blockcodecs/codecs/legacy_zstd06/CMakeLists.txt
index 783efe8d80..3e0811fb22 100644
--- a/library/cpp/blockcodecs/codecs/legacy_zstd06/CMakeLists.txt
+++ b/library/cpp/blockcodecs/codecs/legacy_zstd06/CMakeLists.txt
@@ -6,22 +6,10 @@
# original buildsystem will not be accepted.
-
-add_library(blockcodecs-codecs-legacy_zstd06 INTERFACE)
-target_link_libraries(blockcodecs-codecs-legacy_zstd06 INTERFACE
- contrib-libs-cxxsupp
- yutil
- contrib-libs-zstd06
- cpp-blockcodecs-core
-)
-
-add_global_library_for(blockcodecs-codecs-legacy_zstd06.global blockcodecs-codecs-legacy_zstd06)
-target_link_libraries(blockcodecs-codecs-legacy_zstd06.global PUBLIC
- contrib-libs-cxxsupp
- yutil
- contrib-libs-zstd06
- cpp-blockcodecs-core
-)
-target_sources(blockcodecs-codecs-legacy_zstd06.global PRIVATE
- ${CMAKE_SOURCE_DIR}/library/cpp/blockcodecs/codecs/legacy_zstd06/legacy_zstd06.cpp
-)
+if (CMAKE_SYSTEM_PROCESSOR STREQUAL "aarch64" AND UNIX AND NOT APPLE AND NOT ANDROID)
+ include(CMakeLists.linux-aarch64.txt)
+elseif (APPLE)
+ include(CMakeLists.darwin.txt)
+elseif (CMAKE_SYSTEM_PROCESSOR STREQUAL "x86_64" AND UNIX AND NOT APPLE AND NOT ANDROID)
+ include(CMakeLists.linux.txt)
+endif()