aboutsummaryrefslogtreecommitdiffstats
path: root/library/cpp/blockcodecs/CMakeLists.txt
diff options
context:
space:
mode:
authorthegeorg <thegeorg@yandex-team.com>2022-12-15 19:25:15 +0300
committerthegeorg <thegeorg@yandex-team.com>2022-12-15 19:25:15 +0300
commit0c31d97afd7858af5f8f858c8addf91655ca9ccc (patch)
tree4d8a246db168f7beaafcd06d486c034115c2123d /library/cpp/blockcodecs/CMakeLists.txt
parentd1d5f5e00df0dd6efc00880dd8283477fc643aaf (diff)
downloadydb-0c31d97afd7858af5f8f858c8addf91655ca9ccc.tar.gz
Sync linux-headers instead of using system ones
Diffstat (limited to 'library/cpp/blockcodecs/CMakeLists.txt')
-rw-r--r--library/cpp/blockcodecs/CMakeLists.txt29
1 files changed, 7 insertions, 22 deletions
diff --git a/library/cpp/blockcodecs/CMakeLists.txt b/library/cpp/blockcodecs/CMakeLists.txt
index 999004c65a..3e0811fb22 100644
--- a/library/cpp/blockcodecs/CMakeLists.txt
+++ b/library/cpp/blockcodecs/CMakeLists.txt
@@ -6,25 +6,10 @@
# original buildsystem will not be accepted.
-add_subdirectory(codecs)
-add_subdirectory(core)
-
-add_library(library-cpp-blockcodecs)
-target_link_libraries(library-cpp-blockcodecs PUBLIC
- contrib-libs-cxxsupp
- yutil
- cpp-blockcodecs-core
- blockcodecs-codecs-brotli
- blockcodecs-codecs-bzip
- blockcodecs-codecs-fastlz
- blockcodecs-codecs-legacy_zstd06
- blockcodecs-codecs-lz4
- blockcodecs-codecs-lzma
- blockcodecs-codecs-snappy
- blockcodecs-codecs-zlib
- blockcodecs-codecs-zstd
-)
-target_sources(library-cpp-blockcodecs PRIVATE
- ${CMAKE_SOURCE_DIR}/library/cpp/blockcodecs/codecs.cpp
- ${CMAKE_SOURCE_DIR}/library/cpp/blockcodecs/stream.cpp
-)
+if (CMAKE_SYSTEM_PROCESSOR STREQUAL "aarch64" AND UNIX AND NOT APPLE AND NOT ANDROID)
+ include(CMakeLists.linux-aarch64.txt)
+elseif (APPLE)
+ include(CMakeLists.darwin.txt)
+elseif (CMAKE_SYSTEM_PROCESSOR STREQUAL "x86_64" AND UNIX AND NOT APPLE AND NOT ANDROID)
+ include(CMakeLists.linux.txt)
+endif()