aboutsummaryrefslogtreecommitdiffstats
path: root/library/cpp/actors/wilson/protos/CMakeLists.txt
diff options
context:
space:
mode:
authorthegeorg <thegeorg@yandex-team.com>2022-12-15 19:25:15 +0300
committerthegeorg <thegeorg@yandex-team.com>2022-12-15 19:25:15 +0300
commit0c31d97afd7858af5f8f858c8addf91655ca9ccc (patch)
tree4d8a246db168f7beaafcd06d486c034115c2123d /library/cpp/actors/wilson/protos/CMakeLists.txt
parentd1d5f5e00df0dd6efc00880dd8283477fc643aaf (diff)
downloadydb-0c31d97afd7858af5f8f858c8addf91655ca9ccc.tar.gz
Sync linux-headers instead of using system ones
Diffstat (limited to 'library/cpp/actors/wilson/protos/CMakeLists.txt')
-rw-r--r--library/cpp/actors/wilson/protos/CMakeLists.txt41
1 files changed, 7 insertions, 34 deletions
diff --git a/library/cpp/actors/wilson/protos/CMakeLists.txt b/library/cpp/actors/wilson/protos/CMakeLists.txt
index f61a5ee58d..3e0811fb22 100644
--- a/library/cpp/actors/wilson/protos/CMakeLists.txt
+++ b/library/cpp/actors/wilson/protos/CMakeLists.txt
@@ -6,37 +6,10 @@
# original buildsystem will not be accepted.
-
-add_library(actors-wilson-protos)
-set_property(TARGET actors-wilson-protos PROPERTY
- PROTOC_EXTRA_OUTS .grpc.pb.cc .grpc.pb.h
-)
-target_link_libraries(actors-wilson-protos PUBLIC
- contrib-libs-cxxsupp
- yutil
- contrib-libs-grpc
- contrib-libs-protobuf
-)
-target_proto_messages(actors-wilson-protos PRIVATE
- ${CMAKE_SOURCE_DIR}/library/cpp/actors/wilson/protos/common.proto
- ${CMAKE_SOURCE_DIR}/library/cpp/actors/wilson/protos/resource.proto
- ${CMAKE_SOURCE_DIR}/library/cpp/actors/wilson/protos/service.proto
- ${CMAKE_SOURCE_DIR}/library/cpp/actors/wilson/protos/trace.proto
-)
-target_proto_addincls(actors-wilson-protos
- ./
- ${CMAKE_SOURCE_DIR}/
- ${CMAKE_BINARY_DIR}
- ${CMAKE_SOURCE_DIR}
- ${CMAKE_SOURCE_DIR}/contrib/libs/protobuf/src
- ${CMAKE_BINARY_DIR}
- ${CMAKE_SOURCE_DIR}/contrib/libs/protobuf/src
-)
-target_proto_outs(actors-wilson-protos
- --cpp_out=${CMAKE_BINARY_DIR}/
- --cpp_styleguide_out=${CMAKE_BINARY_DIR}/
-)
-target_proto_plugin(actors-wilson-protos
- grpc_cpp
- grpc_cpp
-)
+if (CMAKE_SYSTEM_PROCESSOR STREQUAL "aarch64" AND UNIX AND NOT APPLE AND NOT ANDROID)
+ include(CMakeLists.linux-aarch64.txt)
+elseif (APPLE)
+ include(CMakeLists.darwin.txt)
+elseif (CMAKE_SYSTEM_PROCESSOR STREQUAL "x86_64" AND UNIX AND NOT APPLE AND NOT ANDROID)
+ include(CMakeLists.linux.txt)
+endif()