aboutsummaryrefslogtreecommitdiffstats
path: root/contrib/tools/protoc/plugins/grpc_cpp/CMakeLists.txt
diff options
context:
space:
mode:
authorrobot-ya-builder <robot-ya-builder@yandex-team.com>2023-01-31 06:43:37 +0300
committerrobot-ya-builder <robot-ya-builder@yandex-team.com>2023-01-31 06:43:37 +0300
commit84d8b69eb78329102350117cecd3789f6b0a76bc (patch)
tree65f770030ef9c51cd1f8958361098777552777ce /contrib/tools/protoc/plugins/grpc_cpp/CMakeLists.txt
parent58f259d0f1f2997f29bab23cee45b6fdfb2792d8 (diff)
downloadydb-84d8b69eb78329102350117cecd3789f6b0a76bc.tar.gz
External build system generator release 12
Update tools: yexport
Diffstat (limited to 'contrib/tools/protoc/plugins/grpc_cpp/CMakeLists.txt')
-rw-r--r--contrib/tools/protoc/plugins/grpc_cpp/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/contrib/tools/protoc/plugins/grpc_cpp/CMakeLists.txt b/contrib/tools/protoc/plugins/grpc_cpp/CMakeLists.txt
index bede1861df..5bb4faffb4 100644
--- a/contrib/tools/protoc/plugins/grpc_cpp/CMakeLists.txt
+++ b/contrib/tools/protoc/plugins/grpc_cpp/CMakeLists.txt
@@ -8,7 +8,7 @@
if (CMAKE_SYSTEM_PROCESSOR STREQUAL "aarch64" AND UNIX AND NOT APPLE AND NOT ANDROID)
include(CMakeLists.linux-aarch64.txt)
-elseif (APPLE)
+elseif (APPLE AND CMAKE_SYSTEM_PROCESSOR STREQUAL "x86_64")
include(CMakeLists.darwin.txt)
elseif (CMAKE_SYSTEM_PROCESSOR STREQUAL "x86_64" AND UNIX AND NOT APPLE AND NOT ANDROID)
include(CMakeLists.linux.txt)