aboutsummaryrefslogtreecommitdiffstats
path: root/contrib/restricted/boost/tuple/CMakeLists.txt
diff options
context:
space:
mode:
authorbugaevskiy <bugaevskiy@yandex-team.com>2022-07-28 22:48:34 +0300
committerbugaevskiy <bugaevskiy@yandex-team.com>2022-07-28 22:48:34 +0300
commit2b2db76e99526303504b01101d94815ba6e2c485 (patch)
treee8d99c4cb73e47308c8101247bd482b881e10180 /contrib/restricted/boost/tuple/CMakeLists.txt
parent92821b50913cc003e8a06d919fb2fade5a81dead (diff)
downloadydb-2b2db76e99526303504b01101d94815ba6e2c485.tar.gz
Reimport boost/tuple as a separate project
Diffstat (limited to 'contrib/restricted/boost/tuple/CMakeLists.txt')
-rw-r--r--contrib/restricted/boost/tuple/CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/contrib/restricted/boost/tuple/CMakeLists.txt b/contrib/restricted/boost/tuple/CMakeLists.txt
new file mode 100644
index 0000000000..a3ec6b8b63
--- /dev/null
+++ b/contrib/restricted/boost/tuple/CMakeLists.txt
@@ -0,0 +1,21 @@
+
+# This file was gererated by the build system used internally in the Yandex monorepo.
+# Only simple modifications are allowed (adding source-files to targets, adding simple properties
+# like target_include_directories). These modifications will be ported to original
+# ya.make files by maintainers. Any complex modifications which can't be ported back to the
+# original buildsystem will not be accepted.
+
+
+
+add_library(restricted-boost-tuple INTERFACE)
+target_include_directories(restricted-boost-tuple INTERFACE
+ ${CMAKE_SOURCE_DIR}/contrib/restricted/boost/tuple/include
+)
+target_link_libraries(restricted-boost-tuple INTERFACE
+ contrib-libs-cxxsupp
+ yutil
+ restricted-boost-config
+ restricted-boost-core
+ restricted-boost-static_assert
+ restricted-boost-type_traits
+)