aboutsummaryrefslogtreecommitdiffstats
path: root/contrib/restricted/boost/spirit/CMakeLists.txt
diff options
context:
space:
mode:
authorthegeorg <thegeorg@yandex-team.com>2022-12-15 19:25:15 +0300
committerthegeorg <thegeorg@yandex-team.com>2022-12-15 19:25:15 +0300
commit0c31d97afd7858af5f8f858c8addf91655ca9ccc (patch)
tree4d8a246db168f7beaafcd06d486c034115c2123d /contrib/restricted/boost/spirit/CMakeLists.txt
parentd1d5f5e00df0dd6efc00880dd8283477fc643aaf (diff)
downloadydb-0c31d97afd7858af5f8f858c8addf91655ca9ccc.tar.gz
Sync linux-headers instead of using system ones
Diffstat (limited to 'contrib/restricted/boost/spirit/CMakeLists.txt')
-rw-r--r--contrib/restricted/boost/spirit/CMakeLists.txt55
1 files changed, 7 insertions, 48 deletions
diff --git a/contrib/restricted/boost/spirit/CMakeLists.txt b/contrib/restricted/boost/spirit/CMakeLists.txt
index 70770f16ae..3e0811fb22 100644
--- a/contrib/restricted/boost/spirit/CMakeLists.txt
+++ b/contrib/restricted/boost/spirit/CMakeLists.txt
@@ -6,51 +6,10 @@
# original buildsystem will not be accepted.
-
-add_library(restricted-boost-spirit INTERFACE)
-target_include_directories(restricted-boost-spirit INTERFACE
- ${CMAKE_SOURCE_DIR}/contrib/restricted/boost/spirit/include
-)
-target_link_libraries(restricted-boost-spirit INTERFACE
- contrib-libs-cxxsupp
- yutil
- restricted-boost-algorithm
- restricted-boost-array
- restricted-boost-assert
- restricted-boost-concept_check
- restricted-boost-config
- restricted-boost-core
- restricted-boost-endian
- restricted-boost-filesystem
- restricted-boost-foreach
- restricted-boost-function
- restricted-boost-function_types
- restricted-boost-fusion
- restricted-boost-integer
- restricted-boost-io
- restricted-boost-iostreams
- restricted-boost-iterator
- restricted-boost-lexical_cast
- restricted-boost-locale
- restricted-boost-math
- restricted-boost-move
- restricted-boost-mpl
- restricted-boost-optional
- restricted-boost-phoenix
- restricted-boost-pool
- restricted-boost-predef
- restricted-boost-preprocessor
- restricted-boost-proto
- restricted-boost-range
- restricted-boost-regex
- restricted-boost-smart_ptr
- restricted-boost-static_assert
- restricted-boost-thread
- restricted-boost-throw_exception
- restricted-boost-tti
- restricted-boost-type_traits
- restricted-boost-typeof
- restricted-boost-unordered
- restricted-boost-utility
- restricted-boost-variant
-)
+if (CMAKE_SYSTEM_PROCESSOR STREQUAL "aarch64" AND UNIX AND NOT APPLE AND NOT ANDROID)
+ include(CMakeLists.linux-aarch64.txt)
+elseif (APPLE)
+ include(CMakeLists.darwin.txt)
+elseif (CMAKE_SYSTEM_PROCESSOR STREQUAL "x86_64" AND UNIX AND NOT APPLE AND NOT ANDROID)
+ include(CMakeLists.linux.txt)
+endif()