aboutsummaryrefslogtreecommitdiffstats
path: root/contrib/restricted/boost/ptr_container/CMakeLists.txt
diff options
context:
space:
mode:
authorbugaevskiy <bugaevskiy@yandex-team.com>2022-09-09 06:22:32 +0300
committerbugaevskiy <bugaevskiy@yandex-team.com>2022-09-09 06:22:32 +0300
commit4ec683e3f8d8404a356a84b481d4f719e0c10f48 (patch)
tree1d900748682d06fcc678b5d253774c3c57515641 /contrib/restricted/boost/ptr_container/CMakeLists.txt
parent3a9a5a35b061c4dcf40f8eda7b2c367cbf407fb9 (diff)
downloadydb-4ec683e3f8d8404a356a84b481d4f719e0c10f48.tar.gz
Reimport boost/ptr_container as a separate project
Diffstat (limited to 'contrib/restricted/boost/ptr_container/CMakeLists.txt')
-rw-r--r--contrib/restricted/boost/ptr_container/CMakeLists.txt31
1 files changed, 31 insertions, 0 deletions
diff --git a/contrib/restricted/boost/ptr_container/CMakeLists.txt b/contrib/restricted/boost/ptr_container/CMakeLists.txt
new file mode 100644
index 0000000000..a173adc428
--- /dev/null
+++ b/contrib/restricted/boost/ptr_container/CMakeLists.txt
@@ -0,0 +1,31 @@
+
+# This file was gererated by the build system used internally in the Yandex monorepo.
+# Only simple modifications are allowed (adding source-files to targets, adding simple properties
+# like target_include_directories). These modifications will be ported to original
+# ya.make files by maintainers. Any complex modifications which can't be ported back to the
+# original buildsystem will not be accepted.
+
+
+
+add_library(restricted-boost-ptr_container INTERFACE)
+target_include_directories(restricted-boost-ptr_container INTERFACE
+ ${CMAKE_SOURCE_DIR}/contrib/restricted/boost/ptr_container/include
+)
+target_link_libraries(restricted-boost-ptr_container INTERFACE
+ contrib-libs-cxxsupp
+ yutil
+ restricted-boost-array
+ restricted-boost-assert
+ restricted-boost-circular_buffer
+ restricted-boost-config
+ restricted-boost-core
+ restricted-boost-iterator
+ restricted-boost-mpl
+ restricted-boost-range
+ restricted-boost-serialization
+ restricted-boost-smart_ptr
+ restricted-boost-static_assert
+ restricted-boost-type_traits
+ restricted-boost-unordered
+ restricted-boost-utility
+)