aboutsummaryrefslogtreecommitdiffstats
path: root/contrib/restricted/boost/program_options/CMakeLists.txt
diff options
context:
space:
mode:
authorbugaevskiy <bugaevskiy@yandex-team.com>2022-08-20 20:59:12 +0300
committerbugaevskiy <bugaevskiy@yandex-team.com>2022-08-20 20:59:12 +0300
commit84b2949407f15cbe65233bc61b836c6b13a9b51d (patch)
tree08bba0f3b65fae0b146d07b9af890dd87aac0f17 /contrib/restricted/boost/program_options/CMakeLists.txt
parentd95f2491195efbc546af6bb237fabaf95bc9953e (diff)
downloadydb-84b2949407f15cbe65233bc61b836c6b13a9b51d.tar.gz
Reimport boost/program_options as a separate project
Diffstat (limited to 'contrib/restricted/boost/program_options/CMakeLists.txt')
-rw-r--r--contrib/restricted/boost/program_options/CMakeLists.txt42
1 files changed, 42 insertions, 0 deletions
diff --git a/contrib/restricted/boost/program_options/CMakeLists.txt b/contrib/restricted/boost/program_options/CMakeLists.txt
new file mode 100644
index 0000000000..7cc1ef0215
--- /dev/null
+++ b/contrib/restricted/boost/program_options/CMakeLists.txt
@@ -0,0 +1,42 @@
+
+# This file was gererated by the build system used internally in the Yandex monorepo.
+# Only simple modifications are allowed (adding source-files to targets, adding simple properties
+# like target_include_directories). These modifications will be ported to original
+# ya.make files by maintainers. Any complex modifications which can't be ported back to the
+# original buildsystem will not be accepted.
+
+
+
+add_library(restricted-boost-program_options)
+target_include_directories(restricted-boost-program_options PUBLIC
+ ${CMAKE_SOURCE_DIR}/contrib/restricted/boost/program_options/include
+)
+target_link_libraries(restricted-boost-program_options PUBLIC
+ contrib-libs-cxxsupp
+ yutil
+ restricted-boost-any
+ restricted-boost-config
+ restricted-boost-core
+ restricted-boost-detail
+ restricted-boost-function
+ restricted-boost-iterator
+ restricted-boost-lexical_cast
+ restricted-boost-smart_ptr
+ restricted-boost-static_assert
+ restricted-boost-throw_exception
+ restricted-boost-tokenizer
+ restricted-boost-type_traits
+)
+target_sources(restricted-boost-program_options PRIVATE
+ ${CMAKE_SOURCE_DIR}/contrib/restricted/boost/program_options/src/cmdline.cpp
+ ${CMAKE_SOURCE_DIR}/contrib/restricted/boost/program_options/src/config_file.cpp
+ ${CMAKE_SOURCE_DIR}/contrib/restricted/boost/program_options/src/convert.cpp
+ ${CMAKE_SOURCE_DIR}/contrib/restricted/boost/program_options/src/options_description.cpp
+ ${CMAKE_SOURCE_DIR}/contrib/restricted/boost/program_options/src/parsers.cpp
+ ${CMAKE_SOURCE_DIR}/contrib/restricted/boost/program_options/src/positional_options.cpp
+ ${CMAKE_SOURCE_DIR}/contrib/restricted/boost/program_options/src/split.cpp
+ ${CMAKE_SOURCE_DIR}/contrib/restricted/boost/program_options/src/utf8_codecvt_facet.cpp
+ ${CMAKE_SOURCE_DIR}/contrib/restricted/boost/program_options/src/value_semantic.cpp
+ ${CMAKE_SOURCE_DIR}/contrib/restricted/boost/program_options/src/variables_map.cpp
+ ${CMAKE_SOURCE_DIR}/contrib/restricted/boost/program_options/src/winmain.cpp
+)