aboutsummaryrefslogtreecommitdiffstats
path: root/contrib/restricted/boost/polygon/CMakeLists.txt
diff options
context:
space:
mode:
authorbugaevskiy <bugaevskiy@yandex-team.com>2022-08-06 16:20:48 +0300
committerbugaevskiy <bugaevskiy@yandex-team.com>2022-08-06 16:20:48 +0300
commit539aa27ec83e9e9b91d482a713fab0d3becfd4ee (patch)
tree13764227d34f75df1d98c9f7611d3be2016865a0 /contrib/restricted/boost/polygon/CMakeLists.txt
parent917b626b554722237d40288db91f6b26e2d25759 (diff)
downloadydb-539aa27ec83e9e9b91d482a713fab0d3becfd4ee.tar.gz
Reimport boost/polygon as a separate project
Diffstat (limited to 'contrib/restricted/boost/polygon/CMakeLists.txt')
-rw-r--r--contrib/restricted/boost/polygon/CMakeLists.txt20
1 files changed, 20 insertions, 0 deletions
diff --git a/contrib/restricted/boost/polygon/CMakeLists.txt b/contrib/restricted/boost/polygon/CMakeLists.txt
new file mode 100644
index 0000000000..bdee2a86e8
--- /dev/null
+++ b/contrib/restricted/boost/polygon/CMakeLists.txt
@@ -0,0 +1,20 @@
+
+# This file was gererated by the build system used internally in the Yandex monorepo.
+# Only simple modifications are allowed (adding source-files to targets, adding simple properties
+# like target_include_directories). These modifications will be ported to original
+# ya.make files by maintainers. Any complex modifications which can't be ported back to the
+# original buildsystem will not be accepted.
+
+
+
+add_library(restricted-boost-polygon INTERFACE)
+target_include_directories(restricted-boost-polygon INTERFACE
+ ${CMAKE_SOURCE_DIR}/contrib/restricted/boost/polygon/include
+)
+target_link_libraries(restricted-boost-polygon INTERFACE
+ contrib-libs-cxxsupp
+ yutil
+ restricted-boost-config
+ restricted-boost-core
+ restricted-boost-mpl
+)