aboutsummaryrefslogtreecommitdiffstats
path: root/contrib/restricted/boost/phoenix/CMakeLists.txt
diff options
context:
space:
mode:
authorbugaevskiy <bugaevskiy@yandex-team.com>2022-08-15 06:13:11 +0300
committerbugaevskiy <bugaevskiy@yandex-team.com>2022-08-15 06:13:11 +0300
commitd63207b17f00c7b8f8894733d6d0e7e2816849ad (patch)
treec307ce534b8db3e954e5fae1794266d9ad282953 /contrib/restricted/boost/phoenix/CMakeLists.txt
parent8016a3961c382e8271812896f6d47ce9079d2023 (diff)
downloadydb-d63207b17f00c7b8f8894733d6d0e7e2816849ad.tar.gz
Reimport boost/phoenix as a separate project
Diffstat (limited to 'contrib/restricted/boost/phoenix/CMakeLists.txt')
-rw-r--r--contrib/restricted/boost/phoenix/CMakeLists.txt31
1 files changed, 31 insertions, 0 deletions
diff --git a/contrib/restricted/boost/phoenix/CMakeLists.txt b/contrib/restricted/boost/phoenix/CMakeLists.txt
new file mode 100644
index 0000000000..2f22b5f225
--- /dev/null
+++ b/contrib/restricted/boost/phoenix/CMakeLists.txt
@@ -0,0 +1,31 @@
+
+# This file was gererated by the build system used internally in the Yandex monorepo.
+# Only simple modifications are allowed (adding source-files to targets, adding simple properties
+# like target_include_directories). These modifications will be ported to original
+# ya.make files by maintainers. Any complex modifications which can't be ported back to the
+# original buildsystem will not be accepted.
+
+
+
+add_library(restricted-boost-phoenix INTERFACE)
+target_include_directories(restricted-boost-phoenix INTERFACE
+ ${CMAKE_SOURCE_DIR}/contrib/restricted/boost/phoenix/include
+)
+target_link_libraries(restricted-boost-phoenix INTERFACE
+ contrib-libs-cxxsupp
+ yutil
+ restricted-boost-assert
+ restricted-boost-bind
+ restricted-boost-config
+ restricted-boost-core
+ restricted-boost-function
+ restricted-boost-fusion
+ restricted-boost-mpl
+ restricted-boost-predef
+ restricted-boost-preprocessor
+ restricted-boost-proto
+ restricted-boost-range
+ restricted-boost-smart_ptr
+ restricted-boost-type_traits
+ restricted-boost-utility
+)