aboutsummaryrefslogtreecommitdiffstats
path: root/contrib/restricted/boost/multiprecision/CMakeLists.txt
diff options
context:
space:
mode:
authorbugaevskiy <bugaevskiy@yandex-team.com>2022-08-23 11:05:33 +0300
committerbugaevskiy <bugaevskiy@yandex-team.com>2022-08-23 11:05:33 +0300
commit41e5df041415ca76c8839340ca9c2337ef2e87c1 (patch)
treef62a2c65613d378c6add970dcafa4bba5fe736d3 /contrib/restricted/boost/multiprecision/CMakeLists.txt
parent7fa4794ae863385f878e104405cd03f1066ec24c (diff)
downloadydb-41e5df041415ca76c8839340ca9c2337ef2e87c1.tar.gz
Reimport boost/multiprecision as a separate project
Diffstat (limited to 'contrib/restricted/boost/multiprecision/CMakeLists.txt')
-rw-r--r--contrib/restricted/boost/multiprecision/CMakeLists.txt33
1 files changed, 33 insertions, 0 deletions
diff --git a/contrib/restricted/boost/multiprecision/CMakeLists.txt b/contrib/restricted/boost/multiprecision/CMakeLists.txt
new file mode 100644
index 0000000000..b7fb0528f6
--- /dev/null
+++ b/contrib/restricted/boost/multiprecision/CMakeLists.txt
@@ -0,0 +1,33 @@
+
+# This file was gererated by the build system used internally in the Yandex monorepo.
+# Only simple modifications are allowed (adding source-files to targets, adding simple properties
+# like target_include_directories). These modifications will be ported to original
+# ya.make files by maintainers. Any complex modifications which can't be ported back to the
+# original buildsystem will not be accepted.
+
+
+
+add_library(restricted-boost-multiprecision INTERFACE)
+target_include_directories(restricted-boost-multiprecision INTERFACE
+ ${CMAKE_SOURCE_DIR}/contrib/restricted/boost/multiprecision/include
+)
+target_link_libraries(restricted-boost-multiprecision INTERFACE
+ contrib-libs-cxxsupp
+ yutil
+ restricted-boost-array
+ restricted-boost-assert
+ restricted-boost-config
+ restricted-boost-container_hash
+ restricted-boost-core
+ restricted-boost-integer
+ restricted-boost-lexical_cast
+ restricted-boost-math
+ restricted-boost-mpl
+ restricted-boost-predef
+ restricted-boost-random
+ restricted-boost-rational
+ restricted-boost-smart_ptr
+ restricted-boost-static_assert
+ restricted-boost-throw_exception
+ restricted-boost-type_traits
+)