aboutsummaryrefslogtreecommitdiffstats
path: root/contrib/restricted/boost/locale/CMakeLists.txt
diff options
context:
space:
mode:
authorthegeorg <thegeorg@yandex-team.com>2022-12-15 19:25:15 +0300
committerthegeorg <thegeorg@yandex-team.com>2022-12-15 19:25:15 +0300
commit0c31d97afd7858af5f8f858c8addf91655ca9ccc (patch)
tree4d8a246db168f7beaafcd06d486c034115c2123d /contrib/restricted/boost/locale/CMakeLists.txt
parentd1d5f5e00df0dd6efc00880dd8283477fc643aaf (diff)
downloadydb-0c31d97afd7858af5f8f858c8addf91655ca9ccc.tar.gz
Sync linux-headers instead of using system ones
Diffstat (limited to 'contrib/restricted/boost/locale/CMakeLists.txt')
-rw-r--r--contrib/restricted/boost/locale/CMakeLists.txt69
1 files changed, 7 insertions, 62 deletions
diff --git a/contrib/restricted/boost/locale/CMakeLists.txt b/contrib/restricted/boost/locale/CMakeLists.txt
index 6923f40331..3e0811fb22 100644
--- a/contrib/restricted/boost/locale/CMakeLists.txt
+++ b/contrib/restricted/boost/locale/CMakeLists.txt
@@ -6,65 +6,10 @@
# original buildsystem will not be accepted.
-
-add_library(restricted-boost-locale)
-target_compile_options(restricted-boost-locale PRIVATE
- -DBOOST_LOCALE_WITH_ICU
- -DBOOST_LOCALE_NO_WINAPI_BACKEND
- -Wno-everything
-)
-target_include_directories(restricted-boost-locale PUBLIC
- ${CMAKE_SOURCE_DIR}/contrib/restricted/boost/locale/include
-)
-target_include_directories(restricted-boost-locale PRIVATE
- ${CMAKE_SOURCE_DIR}/contrib/restricted/boost/locale/src
-)
-target_link_libraries(restricted-boost-locale PUBLIC
- contrib-libs-cxxsupp
- contrib-libs-icu
- restricted-boost-assert
- restricted-boost-config
- restricted-boost-function
- restricted-boost-iterator
- restricted-boost-predef
- restricted-boost-smart_ptr
- restricted-boost-static_assert
- restricted-boost-thread
- restricted-boost-type_traits
- restricted-boost-unordered
-)
-target_sources(restricted-boost-locale PRIVATE
- ${CMAKE_SOURCE_DIR}/contrib/restricted/boost/locale/src/boost/locale/posix/codecvt.cpp
- ${CMAKE_SOURCE_DIR}/contrib/restricted/boost/locale/src/boost/locale/posix/collate.cpp
- ${CMAKE_SOURCE_DIR}/contrib/restricted/boost/locale/src/boost/locale/posix/converter.cpp
- ${CMAKE_SOURCE_DIR}/contrib/restricted/boost/locale/src/boost/locale/posix/numeric.cpp
- ${CMAKE_SOURCE_DIR}/contrib/restricted/boost/locale/src/boost/locale/posix/posix_backend.cpp
- ${CMAKE_SOURCE_DIR}/contrib/restricted/boost/locale/src/boost/locale/encoding/codepage.cpp
- ${CMAKE_SOURCE_DIR}/contrib/restricted/boost/locale/src/boost/locale/icu/boundary.cpp
- ${CMAKE_SOURCE_DIR}/contrib/restricted/boost/locale/src/boost/locale/icu/codecvt.cpp
- ${CMAKE_SOURCE_DIR}/contrib/restricted/boost/locale/src/boost/locale/icu/collator.cpp
- ${CMAKE_SOURCE_DIR}/contrib/restricted/boost/locale/src/boost/locale/icu/conversion.cpp
- ${CMAKE_SOURCE_DIR}/contrib/restricted/boost/locale/src/boost/locale/icu/date_time.cpp
- ${CMAKE_SOURCE_DIR}/contrib/restricted/boost/locale/src/boost/locale/icu/formatter.cpp
- ${CMAKE_SOURCE_DIR}/contrib/restricted/boost/locale/src/boost/locale/icu/icu_backend.cpp
- ${CMAKE_SOURCE_DIR}/contrib/restricted/boost/locale/src/boost/locale/icu/numeric.cpp
- ${CMAKE_SOURCE_DIR}/contrib/restricted/boost/locale/src/boost/locale/icu/time_zone.cpp
- ${CMAKE_SOURCE_DIR}/contrib/restricted/boost/locale/src/boost/locale/shared/date_time.cpp
- ${CMAKE_SOURCE_DIR}/contrib/restricted/boost/locale/src/boost/locale/shared/format.cpp
- ${CMAKE_SOURCE_DIR}/contrib/restricted/boost/locale/src/boost/locale/shared/formatting.cpp
- ${CMAKE_SOURCE_DIR}/contrib/restricted/boost/locale/src/boost/locale/shared/generator.cpp
- ${CMAKE_SOURCE_DIR}/contrib/restricted/boost/locale/src/boost/locale/shared/ids.cpp
- ${CMAKE_SOURCE_DIR}/contrib/restricted/boost/locale/src/boost/locale/shared/localization_backend.cpp
- ${CMAKE_SOURCE_DIR}/contrib/restricted/boost/locale/src/boost/locale/shared/message.cpp
- ${CMAKE_SOURCE_DIR}/contrib/restricted/boost/locale/src/boost/locale/shared/mo_lambda.cpp
- ${CMAKE_SOURCE_DIR}/contrib/restricted/boost/locale/src/boost/locale/std/codecvt.cpp
- ${CMAKE_SOURCE_DIR}/contrib/restricted/boost/locale/src/boost/locale/std/collate.cpp
- ${CMAKE_SOURCE_DIR}/contrib/restricted/boost/locale/src/boost/locale/std/converter.cpp
- ${CMAKE_SOURCE_DIR}/contrib/restricted/boost/locale/src/boost/locale/std/numeric.cpp
- ${CMAKE_SOURCE_DIR}/contrib/restricted/boost/locale/src/boost/locale/std/std_backend.cpp
- ${CMAKE_SOURCE_DIR}/contrib/restricted/boost/locale/src/boost/locale/util/codecvt_converter.cpp
- ${CMAKE_SOURCE_DIR}/contrib/restricted/boost/locale/src/boost/locale/util/default_locale.cpp
- ${CMAKE_SOURCE_DIR}/contrib/restricted/boost/locale/src/boost/locale/util/gregorian.cpp
- ${CMAKE_SOURCE_DIR}/contrib/restricted/boost/locale/src/boost/locale/util/info.cpp
- ${CMAKE_SOURCE_DIR}/contrib/restricted/boost/locale/src/boost/locale/util/locale_data.cpp
-)
+if (CMAKE_SYSTEM_PROCESSOR STREQUAL "aarch64" AND UNIX AND NOT APPLE AND NOT ANDROID)
+ include(CMakeLists.linux-aarch64.txt)
+elseif (APPLE)
+ include(CMakeLists.darwin.txt)
+elseif (CMAKE_SYSTEM_PROCESSOR STREQUAL "x86_64" AND UNIX AND NOT APPLE AND NOT ANDROID)
+ include(CMakeLists.linux.txt)
+endif()