aboutsummaryrefslogtreecommitdiffstats
path: root/contrib/restricted/boost/io/CMakeLists.txt
diff options
context:
space:
mode:
authorbugaevskiy <bugaevskiy@yandex-team.com>2022-07-20 13:13:43 +0300
committerbugaevskiy <bugaevskiy@yandex-team.com>2022-07-20 13:13:43 +0300
commitc01bac066fdbee7941b95494b673f303240cf83a (patch)
treeadc4ecb4548ce382f18c1580620a20c9f7f6f682 /contrib/restricted/boost/io/CMakeLists.txt
parentc4a21555e38eadd62a62113b1935ea66e190ad3c (diff)
downloadydb-c01bac066fdbee7941b95494b673f303240cf83a.tar.gz
Reimport boost/io as a separate project
Diffstat (limited to 'contrib/restricted/boost/io/CMakeLists.txt')
-rw-r--r--contrib/restricted/boost/io/CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/contrib/restricted/boost/io/CMakeLists.txt b/contrib/restricted/boost/io/CMakeLists.txt
new file mode 100644
index 0000000000..1857354981
--- /dev/null
+++ b/contrib/restricted/boost/io/CMakeLists.txt
@@ -0,0 +1,18 @@
+
+# This file was gererated by the build system used internally in the Yandex monorepo.
+# Only simple modifications are allowed (adding source-files to targets, adding simple properties
+# like target_include_directories). These modifications will be ported to original
+# ya.make files by maintainers. Any complex modifications which can't be ported back to the
+# original buildsystem will not be accepted.
+
+
+
+add_library(restricted-boost-io INTERFACE)
+target_include_directories(restricted-boost-io INTERFACE
+ ${CMAKE_SOURCE_DIR}/contrib/restricted/boost/io/include
+)
+target_link_libraries(restricted-boost-io INTERFACE
+ contrib-libs-cxxsupp
+ yutil
+ restricted-boost-config
+)