aboutsummaryrefslogtreecommitdiffstats
path: root/contrib/restricted/boost/icl/CMakeLists.txt
diff options
context:
space:
mode:
authordcherednik <dcherednik@ydb.tech>2022-11-22 13:34:53 +0300
committerdcherednik <dcherednik@ydb.tech>2022-11-22 13:34:53 +0300
commitfced20b9af826fdc3ec0886fe1f9740467ffba72 (patch)
tree6200ffc2db79a07a915454606f78fcd8221780ab /contrib/restricted/boost/icl/CMakeLists.txt
parent3e5907562bf4dae9cf824bd61032a343e2d294fd (diff)
downloadydb-fced20b9af826fdc3ec0886fe1f9740467ffba72.tar.gz
Build hyperscan udf on x86_64 only.
Diffstat (limited to 'contrib/restricted/boost/icl/CMakeLists.txt')
-rw-r--r--contrib/restricted/boost/icl/CMakeLists.txt28
1 files changed, 5 insertions, 23 deletions
diff --git a/contrib/restricted/boost/icl/CMakeLists.txt b/contrib/restricted/boost/icl/CMakeLists.txt
index f74baa7ede..79468a5d8d 100644
--- a/contrib/restricted/boost/icl/CMakeLists.txt
+++ b/contrib/restricted/boost/icl/CMakeLists.txt
@@ -6,26 +6,8 @@
# original buildsystem will not be accepted.
-
-add_library(restricted-boost-icl INTERFACE)
-target_include_directories(restricted-boost-icl INTERFACE
- ${CMAKE_SOURCE_DIR}/contrib/restricted/boost/icl/include
-)
-target_link_libraries(restricted-boost-icl INTERFACE
- contrib-libs-cxxsupp
- restricted-boost-assert
- restricted-boost-concept_check
- restricted-boost-config
- restricted-boost-container
- restricted-boost-core
- restricted-boost-date_time
- restricted-boost-detail
- restricted-boost-iterator
- restricted-boost-move
- restricted-boost-mpl
- restricted-boost-range
- restricted-boost-rational
- restricted-boost-static_assert
- restricted-boost-type_traits
- restricted-boost-utility
-)
+if (APPLE)
+ include(CMakeLists.darwin.txt)
+elseif (CMAKE_SYSTEM_PROCESSOR STREQUAL "x86_64" AND UNIX AND NOT APPLE AND NOT ANDROID)
+ include(CMakeLists.linux.txt)
+endif()