aboutsummaryrefslogtreecommitdiffstats
path: root/contrib/restricted/boost/align/CMakeLists.txt
diff options
context:
space:
mode:
authorbugaevskiy <bugaevskiy@yandex-team.com>2022-07-23 21:28:06 +0300
committerbugaevskiy <bugaevskiy@yandex-team.com>2022-07-23 21:28:06 +0300
commitbdfa64a2dfbfa18015103f731c6017fd61a34842 (patch)
tree17f15b4a5bb4ca6546d19950902d0304175cf1db /contrib/restricted/boost/align/CMakeLists.txt
parent4fdcbb93872d8192072780d5b346e91d229fa951 (diff)
downloadydb-bdfa64a2dfbfa18015103f731c6017fd61a34842.tar.gz
Reimport boost/align as a separate project
Diffstat (limited to 'contrib/restricted/boost/align/CMakeLists.txt')
-rw-r--r--contrib/restricted/boost/align/CMakeLists.txt22
1 files changed, 22 insertions, 0 deletions
diff --git a/contrib/restricted/boost/align/CMakeLists.txt b/contrib/restricted/boost/align/CMakeLists.txt
new file mode 100644
index 0000000000..284887ead4
--- /dev/null
+++ b/contrib/restricted/boost/align/CMakeLists.txt
@@ -0,0 +1,22 @@
+
+# This file was gererated by the build system used internally in the Yandex monorepo.
+# Only simple modifications are allowed (adding source-files to targets, adding simple properties
+# like target_include_directories). These modifications will be ported to original
+# ya.make files by maintainers. Any complex modifications which can't be ported back to the
+# original buildsystem will not be accepted.
+
+
+
+add_library(restricted-boost-align INTERFACE)
+target_include_directories(restricted-boost-align INTERFACE
+ ${CMAKE_SOURCE_DIR}/contrib/restricted/boost/align/include
+)
+target_link_libraries(restricted-boost-align INTERFACE
+ contrib-libs-cxxsupp
+ yutil
+ restricted-boost-assert
+ restricted-boost-config
+ restricted-boost-core
+ restricted-boost-static_assert
+ restricted-boost-throw_exception
+)