aboutsummaryrefslogtreecommitdiffstats
path: root/contrib/restricted/abseil-cpp-tstring/y_absl/container/CMakeLists.txt
diff options
context:
space:
mode:
authorthegeorg <thegeorg@yandex-team.com>2022-12-15 19:25:15 +0300
committerthegeorg <thegeorg@yandex-team.com>2022-12-15 19:25:15 +0300
commit0c31d97afd7858af5f8f858c8addf91655ca9ccc (patch)
tree4d8a246db168f7beaafcd06d486c034115c2123d /contrib/restricted/abseil-cpp-tstring/y_absl/container/CMakeLists.txt
parentd1d5f5e00df0dd6efc00880dd8283477fc643aaf (diff)
downloadydb-0c31d97afd7858af5f8f858c8addf91655ca9ccc.tar.gz
Sync linux-headers instead of using system ones
Diffstat (limited to 'contrib/restricted/abseil-cpp-tstring/y_absl/container/CMakeLists.txt')
-rw-r--r--contrib/restricted/abseil-cpp-tstring/y_absl/container/CMakeLists.txt34
1 files changed, 7 insertions, 27 deletions
diff --git a/contrib/restricted/abseil-cpp-tstring/y_absl/container/CMakeLists.txt b/contrib/restricted/abseil-cpp-tstring/y_absl/container/CMakeLists.txt
index 0f1c6b1b89..3e0811fb22 100644
--- a/contrib/restricted/abseil-cpp-tstring/y_absl/container/CMakeLists.txt
+++ b/contrib/restricted/abseil-cpp-tstring/y_absl/container/CMakeLists.txt
@@ -6,30 +6,10 @@
# original buildsystem will not be accepted.
-
-add_library(abseil-cpp-tstring-y_absl-container)
-target_compile_options(abseil-cpp-tstring-y_absl-container PRIVATE
- -Wno-everything
-)
-target_include_directories(abseil-cpp-tstring-y_absl-container PUBLIC
- ${CMAKE_SOURCE_DIR}/contrib/restricted/abseil-cpp-tstring
-)
-target_link_libraries(abseil-cpp-tstring-y_absl-container PUBLIC
- contrib-libs-cxxsupp
- yutil
- abseil-cpp-tstring-y_absl-base
- abseil-cpp-tstring-y_absl-debugging
- abseil-cpp-tstring-y_absl-hash
- abseil-cpp-tstring-y_absl-memory
- abseil-cpp-tstring-y_absl-numeric
- abseil-cpp-tstring-y_absl-profiling
- abseil-cpp-tstring-y_absl-strings
- abseil-cpp-tstring-y_absl-synchronization
- abseil-cpp-tstring-y_absl-time
- abseil-cpp-tstring-y_absl-types
-)
-target_sources(abseil-cpp-tstring-y_absl-container PRIVATE
- ${CMAKE_SOURCE_DIR}/contrib/restricted/abseil-cpp-tstring/y_absl/container/internal/hashtablez_sampler.cc
- ${CMAKE_SOURCE_DIR}/contrib/restricted/abseil-cpp-tstring/y_absl/container/internal/hashtablez_sampler_force_weak_definition.cc
- ${CMAKE_SOURCE_DIR}/contrib/restricted/abseil-cpp-tstring/y_absl/container/internal/raw_hash_set.cc
-)
+if (CMAKE_SYSTEM_PROCESSOR STREQUAL "aarch64" AND UNIX AND NOT APPLE AND NOT ANDROID)
+ include(CMakeLists.linux-aarch64.txt)
+elseif (APPLE)
+ include(CMakeLists.darwin.txt)
+elseif (CMAKE_SYSTEM_PROCESSOR STREQUAL "x86_64" AND UNIX AND NOT APPLE AND NOT ANDROID)
+ include(CMakeLists.linux.txt)
+endif()