aboutsummaryrefslogtreecommitdiffstats
path: root/contrib/libs/poco/JSON/CMakeLists.txt
diff options
context:
space:
mode:
authorvvvv <vvvv@ydb.tech>2022-08-08 14:43:22 +0300
committervvvv <vvvv@ydb.tech>2022-08-08 14:43:22 +0300
commitf5e8e19af3bc909fdb2e42501b3befcb9940f445 (patch)
treea25aeef3a430071fcf64442925423cabace52548 /contrib/libs/poco/JSON/CMakeLists.txt
parentcd5f1d506209511017e977c7a7b53c4779d5adb1 (diff)
downloadydb-f5e8e19af3bc909fdb2e42501b3befcb9940f445.tar.gz
fix darwin build
Diffstat (limited to 'contrib/libs/poco/JSON/CMakeLists.txt')
-rw-r--r--contrib/libs/poco/JSON/CMakeLists.txt34
1 files changed, 31 insertions, 3 deletions
diff --git a/contrib/libs/poco/JSON/CMakeLists.txt b/contrib/libs/poco/JSON/CMakeLists.txt
index e8c98bfd99..121ceef23a 100644
--- a/contrib/libs/poco/JSON/CMakeLists.txt
+++ b/contrib/libs/poco/JSON/CMakeLists.txt
@@ -6,6 +6,34 @@
# original buildsystem will not be accepted.
-if (UNIX AND NOT APPLE)
- include(CMakeLists.linux.txt)
-endif()
+
+add_library(libs-poco-JSON)
+target_compile_options(libs-poco-JSON PRIVATE
+ -Wno-everything
+)
+target_include_directories(libs-poco-JSON PUBLIC
+ ${CMAKE_SOURCE_DIR}/contrib/libs/poco/JSON/include
+)
+target_include_directories(libs-poco-JSON PRIVATE
+ ${CMAKE_SOURCE_DIR}/contrib/libs/poco/Foundation/include
+ ${CMAKE_SOURCE_DIR}/contrib/libs/poco/JSON/src
+)
+target_link_libraries(libs-poco-JSON PUBLIC
+ contrib-libs-cxxsupp
+ libs-poco-Foundation
+)
+target_sources(libs-poco-JSON PRIVATE
+ ${CMAKE_SOURCE_DIR}/contrib/libs/poco/JSON/src/Array.cpp
+ ${CMAKE_SOURCE_DIR}/contrib/libs/poco/JSON/src/Handler.cpp
+ ${CMAKE_SOURCE_DIR}/contrib/libs/poco/JSON/src/JSONException.cpp
+ ${CMAKE_SOURCE_DIR}/contrib/libs/poco/JSON/src/Object.cpp
+ ${CMAKE_SOURCE_DIR}/contrib/libs/poco/JSON/src/ParseHandler.cpp
+ ${CMAKE_SOURCE_DIR}/contrib/libs/poco/JSON/src/Parser.cpp
+ ${CMAKE_SOURCE_DIR}/contrib/libs/poco/JSON/src/ParserImpl.cpp
+ ${CMAKE_SOURCE_DIR}/contrib/libs/poco/JSON/src/PrintHandler.cpp
+ ${CMAKE_SOURCE_DIR}/contrib/libs/poco/JSON/src/Query.cpp
+ ${CMAKE_SOURCE_DIR}/contrib/libs/poco/JSON/src/Stringifier.cpp
+ ${CMAKE_SOURCE_DIR}/contrib/libs/poco/JSON/src/Template.cpp
+ ${CMAKE_SOURCE_DIR}/contrib/libs/poco/JSON/src/TemplateCache.cpp
+ ${CMAKE_SOURCE_DIR}/contrib/libs/poco/JSON/src/pdjson.c
+)