aboutsummaryrefslogtreecommitdiffstats
path: root/contrib/libs/nghttp2/CMakeLists.txt
diff options
context:
space:
mode:
authorthegeorg <thegeorg@yandex-team.com>2022-12-15 19:25:15 +0300
committerthegeorg <thegeorg@yandex-team.com>2022-12-15 19:25:15 +0300
commit0c31d97afd7858af5f8f858c8addf91655ca9ccc (patch)
tree4d8a246db168f7beaafcd06d486c034115c2123d /contrib/libs/nghttp2/CMakeLists.txt
parentd1d5f5e00df0dd6efc00880dd8283477fc643aaf (diff)
downloadydb-0c31d97afd7858af5f8f858c8addf91655ca9ccc.tar.gz
Sync linux-headers instead of using system ones
Diffstat (limited to 'contrib/libs/nghttp2/CMakeLists.txt')
-rw-r--r--contrib/libs/nghttp2/CMakeLists.txt46
1 files changed, 7 insertions, 39 deletions
diff --git a/contrib/libs/nghttp2/CMakeLists.txt b/contrib/libs/nghttp2/CMakeLists.txt
index 2ca8c3590a..3e0811fb22 100644
--- a/contrib/libs/nghttp2/CMakeLists.txt
+++ b/contrib/libs/nghttp2/CMakeLists.txt
@@ -6,42 +6,10 @@
# original buildsystem will not be accepted.
-
-add_library(contrib-libs-nghttp2)
-target_compile_options(contrib-libs-nghttp2 PRIVATE
- -DBUILDING_NGHTTP2
- -DHAVE_CONFIG_H
- -Wno-everything
-)
-target_include_directories(contrib-libs-nghttp2 PUBLIC
- ${CMAKE_SOURCE_DIR}/contrib/libs/nghttp2/lib/includes
-)
-target_include_directories(contrib-libs-nghttp2 PRIVATE
- ${CMAKE_SOURCE_DIR}/contrib/libs/nghttp2
- ${CMAKE_SOURCE_DIR}/contrib/libs/nghttp2/lib
-)
-target_sources(contrib-libs-nghttp2 PRIVATE
- ${CMAKE_SOURCE_DIR}/contrib/libs/nghttp2/lib/nghttp2_buf.c
- ${CMAKE_SOURCE_DIR}/contrib/libs/nghttp2/lib/nghttp2_callbacks.c
- ${CMAKE_SOURCE_DIR}/contrib/libs/nghttp2/lib/nghttp2_debug.c
- ${CMAKE_SOURCE_DIR}/contrib/libs/nghttp2/lib/nghttp2_extpri.c
- ${CMAKE_SOURCE_DIR}/contrib/libs/nghttp2/lib/nghttp2_frame.c
- ${CMAKE_SOURCE_DIR}/contrib/libs/nghttp2/lib/nghttp2_hd.c
- ${CMAKE_SOURCE_DIR}/contrib/libs/nghttp2/lib/nghttp2_hd_huffman.c
- ${CMAKE_SOURCE_DIR}/contrib/libs/nghttp2/lib/nghttp2_hd_huffman_data.c
- ${CMAKE_SOURCE_DIR}/contrib/libs/nghttp2/lib/nghttp2_helper.c
- ${CMAKE_SOURCE_DIR}/contrib/libs/nghttp2/lib/nghttp2_http.c
- ${CMAKE_SOURCE_DIR}/contrib/libs/nghttp2/lib/nghttp2_map.c
- ${CMAKE_SOURCE_DIR}/contrib/libs/nghttp2/lib/nghttp2_mem.c
- ${CMAKE_SOURCE_DIR}/contrib/libs/nghttp2/lib/nghttp2_npn.c
- ${CMAKE_SOURCE_DIR}/contrib/libs/nghttp2/lib/nghttp2_option.c
- ${CMAKE_SOURCE_DIR}/contrib/libs/nghttp2/lib/nghttp2_outbound_item.c
- ${CMAKE_SOURCE_DIR}/contrib/libs/nghttp2/lib/nghttp2_pq.c
- ${CMAKE_SOURCE_DIR}/contrib/libs/nghttp2/lib/nghttp2_priority_spec.c
- ${CMAKE_SOURCE_DIR}/contrib/libs/nghttp2/lib/nghttp2_queue.c
- ${CMAKE_SOURCE_DIR}/contrib/libs/nghttp2/lib/nghttp2_rcbuf.c
- ${CMAKE_SOURCE_DIR}/contrib/libs/nghttp2/lib/nghttp2_session.c
- ${CMAKE_SOURCE_DIR}/contrib/libs/nghttp2/lib/nghttp2_stream.c
- ${CMAKE_SOURCE_DIR}/contrib/libs/nghttp2/lib/nghttp2_submit.c
- ${CMAKE_SOURCE_DIR}/contrib/libs/nghttp2/lib/nghttp2_version.c
-)
+if (CMAKE_SYSTEM_PROCESSOR STREQUAL "aarch64" AND UNIX AND NOT APPLE AND NOT ANDROID)
+ include(CMakeLists.linux-aarch64.txt)
+elseif (APPLE)
+ include(CMakeLists.darwin.txt)
+elseif (CMAKE_SYSTEM_PROCESSOR STREQUAL "x86_64" AND UNIX AND NOT APPLE AND NOT ANDROID)
+ include(CMakeLists.linux.txt)
+endif()