aboutsummaryrefslogtreecommitdiffstats
path: root/contrib/libs/miniselect/CMakeLists.txt
diff options
context:
space:
mode:
authorvvvv <vvvv@ydb.tech>2023-02-09 19:59:45 +0300
committervvvv <vvvv@ydb.tech>2023-02-09 19:59:45 +0300
commit698b400d09b3c1c7aff6ebf986eb3dc3ced74a08 (patch)
tree75fc45b302da8f3b029a0b8b5730cc004eb5b5aa /contrib/libs/miniselect/CMakeLists.txt
parentabc4875e357da7c917051f7fce5138900938bbfa (diff)
downloadydb-698b400d09b3c1c7aff6ebf986eb3dc3ced74a08.tar.gz
use miniselect
Для запроса %% pragma UseBlocks; SELECT RemoteIP as r FROM `yq-clickbench-local`.`hits_*.parquet` WITH ( format=parquet, SCHEMA ( RemoteIP INTEGER NOT NULL, ) ) order by r limit 5 ; %% время уменьшилось с 0.47c до 0,34с
Diffstat (limited to 'contrib/libs/miniselect/CMakeLists.txt')
-rw-r--r--contrib/libs/miniselect/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/contrib/libs/miniselect/CMakeLists.txt b/contrib/libs/miniselect/CMakeLists.txt
new file mode 100644
index 0000000000..5bb4faffb4
--- /dev/null
+++ b/contrib/libs/miniselect/CMakeLists.txt
@@ -0,0 +1,15 @@
+
+# This file was generated by the build system used internally in the Yandex monorepo.
+# Only simple modifications are allowed (adding source-files to targets, adding simple properties
+# like target_include_directories). These modifications will be ported to original
+# ya.make files by maintainers. Any complex modifications which can't be ported back to the
+# original buildsystem will not be accepted.
+
+
+if (CMAKE_SYSTEM_PROCESSOR STREQUAL "aarch64" AND UNIX AND NOT APPLE AND NOT ANDROID)
+ include(CMakeLists.linux-aarch64.txt)
+elseif (APPLE AND CMAKE_SYSTEM_PROCESSOR STREQUAL "x86_64")
+ include(CMakeLists.darwin.txt)
+elseif (CMAKE_SYSTEM_PROCESSOR STREQUAL "x86_64" AND UNIX AND NOT APPLE AND NOT ANDROID)
+ include(CMakeLists.linux.txt)
+endif()