aboutsummaryrefslogtreecommitdiffstats
path: root/contrib/libs/llvm12/lib/Object/CMakeLists.txt
diff options
context:
space:
mode:
authorthegeorg <thegeorg@yandex-team.com>2022-12-15 19:25:15 +0300
committerthegeorg <thegeorg@yandex-team.com>2022-12-15 19:25:15 +0300
commit0c31d97afd7858af5f8f858c8addf91655ca9ccc (patch)
tree4d8a246db168f7beaafcd06d486c034115c2123d /contrib/libs/llvm12/lib/Object/CMakeLists.txt
parentd1d5f5e00df0dd6efc00880dd8283477fc643aaf (diff)
downloadydb-0c31d97afd7858af5f8f858c8addf91655ca9ccc.tar.gz
Sync linux-headers instead of using system ones
Diffstat (limited to 'contrib/libs/llvm12/lib/Object/CMakeLists.txt')
-rw-r--r--contrib/libs/llvm12/lib/Object/CMakeLists.txt58
1 files changed, 7 insertions, 51 deletions
diff --git a/contrib/libs/llvm12/lib/Object/CMakeLists.txt b/contrib/libs/llvm12/lib/Object/CMakeLists.txt
index c5c3cfe5a8..3e0811fb22 100644
--- a/contrib/libs/llvm12/lib/Object/CMakeLists.txt
+++ b/contrib/libs/llvm12/lib/Object/CMakeLists.txt
@@ -6,54 +6,10 @@
# original buildsystem will not be accepted.
-
-add_library(llvm12-lib-Object)
-target_compile_options(llvm12-lib-Object PRIVATE
- -Wno-everything
-)
-target_include_directories(llvm12-lib-Object PRIVATE
- ${CMAKE_SOURCE_DIR}/contrib/libs/llvm12/lib/Object
-)
-target_link_libraries(llvm12-lib-Object PUBLIC
- contrib-libs-cxxsupp
- contrib-libs-llvm12
- libs-llvm12-include
- llvm12-lib-BinaryFormat
- lib-Bitcode-Reader
- llvm12-lib-IR
- llvm12-lib-MC
- lib-MC-MCParser
- llvm12-lib-Support
- lib-TextAPI-MachO
-)
-target_sources(llvm12-lib-Object PRIVATE
- ${CMAKE_SOURCE_DIR}/contrib/libs/llvm12/lib/Object/Archive.cpp
- ${CMAKE_SOURCE_DIR}/contrib/libs/llvm12/lib/Object/ArchiveWriter.cpp
- ${CMAKE_SOURCE_DIR}/contrib/libs/llvm12/lib/Object/Binary.cpp
- ${CMAKE_SOURCE_DIR}/contrib/libs/llvm12/lib/Object/COFFImportFile.cpp
- ${CMAKE_SOURCE_DIR}/contrib/libs/llvm12/lib/Object/COFFModuleDefinition.cpp
- ${CMAKE_SOURCE_DIR}/contrib/libs/llvm12/lib/Object/COFFObjectFile.cpp
- ${CMAKE_SOURCE_DIR}/contrib/libs/llvm12/lib/Object/Decompressor.cpp
- ${CMAKE_SOURCE_DIR}/contrib/libs/llvm12/lib/Object/ELF.cpp
- ${CMAKE_SOURCE_DIR}/contrib/libs/llvm12/lib/Object/ELFObjectFile.cpp
- ${CMAKE_SOURCE_DIR}/contrib/libs/llvm12/lib/Object/Error.cpp
- ${CMAKE_SOURCE_DIR}/contrib/libs/llvm12/lib/Object/IRObjectFile.cpp
- ${CMAKE_SOURCE_DIR}/contrib/libs/llvm12/lib/Object/IRSymtab.cpp
- ${CMAKE_SOURCE_DIR}/contrib/libs/llvm12/lib/Object/MachOObjectFile.cpp
- ${CMAKE_SOURCE_DIR}/contrib/libs/llvm12/lib/Object/MachOUniversal.cpp
- ${CMAKE_SOURCE_DIR}/contrib/libs/llvm12/lib/Object/MachOUniversalWriter.cpp
- ${CMAKE_SOURCE_DIR}/contrib/libs/llvm12/lib/Object/Minidump.cpp
- ${CMAKE_SOURCE_DIR}/contrib/libs/llvm12/lib/Object/ModuleSymbolTable.cpp
- ${CMAKE_SOURCE_DIR}/contrib/libs/llvm12/lib/Object/Object.cpp
- ${CMAKE_SOURCE_DIR}/contrib/libs/llvm12/lib/Object/ObjectFile.cpp
- ${CMAKE_SOURCE_DIR}/contrib/libs/llvm12/lib/Object/RecordStreamer.cpp
- ${CMAKE_SOURCE_DIR}/contrib/libs/llvm12/lib/Object/RelocationResolver.cpp
- ${CMAKE_SOURCE_DIR}/contrib/libs/llvm12/lib/Object/SymbolSize.cpp
- ${CMAKE_SOURCE_DIR}/contrib/libs/llvm12/lib/Object/SymbolicFile.cpp
- ${CMAKE_SOURCE_DIR}/contrib/libs/llvm12/lib/Object/TapiFile.cpp
- ${CMAKE_SOURCE_DIR}/contrib/libs/llvm12/lib/Object/TapiUniversal.cpp
- ${CMAKE_SOURCE_DIR}/contrib/libs/llvm12/lib/Object/WasmObjectFile.cpp
- ${CMAKE_SOURCE_DIR}/contrib/libs/llvm12/lib/Object/WindowsMachineFlag.cpp
- ${CMAKE_SOURCE_DIR}/contrib/libs/llvm12/lib/Object/WindowsResource.cpp
- ${CMAKE_SOURCE_DIR}/contrib/libs/llvm12/lib/Object/XCOFFObjectFile.cpp
-)
+if (CMAKE_SYSTEM_PROCESSOR STREQUAL "aarch64" AND UNIX AND NOT APPLE AND NOT ANDROID)
+ include(CMakeLists.linux-aarch64.txt)
+elseif (APPLE)
+ include(CMakeLists.darwin.txt)
+elseif (CMAKE_SYSTEM_PROCESSOR STREQUAL "x86_64" AND UNIX AND NOT APPLE AND NOT ANDROID)
+ include(CMakeLists.linux.txt)
+endif()