aboutsummaryrefslogtreecommitdiffstats
path: root/contrib/libs/llvm12/lib/DebugInfo/CodeView/CMakeLists.txt
diff options
context:
space:
mode:
authorthegeorg <thegeorg@yandex-team.com>2022-12-15 19:25:15 +0300
committerthegeorg <thegeorg@yandex-team.com>2022-12-15 19:25:15 +0300
commit0c31d97afd7858af5f8f858c8addf91655ca9ccc (patch)
tree4d8a246db168f7beaafcd06d486c034115c2123d /contrib/libs/llvm12/lib/DebugInfo/CodeView/CMakeLists.txt
parentd1d5f5e00df0dd6efc00880dd8283477fc643aaf (diff)
downloadydb-0c31d97afd7858af5f8f858c8addf91655ca9ccc.tar.gz
Sync linux-headers instead of using system ones
Diffstat (limited to 'contrib/libs/llvm12/lib/DebugInfo/CodeView/CMakeLists.txt')
-rw-r--r--contrib/libs/llvm12/lib/DebugInfo/CodeView/CMakeLists.txt63
1 files changed, 7 insertions, 56 deletions
diff --git a/contrib/libs/llvm12/lib/DebugInfo/CodeView/CMakeLists.txt b/contrib/libs/llvm12/lib/DebugInfo/CodeView/CMakeLists.txt
index 89f6fcd901..3e0811fb22 100644
--- a/contrib/libs/llvm12/lib/DebugInfo/CodeView/CMakeLists.txt
+++ b/contrib/libs/llvm12/lib/DebugInfo/CodeView/CMakeLists.txt
@@ -6,59 +6,10 @@
# original buildsystem will not be accepted.
-
-add_library(lib-DebugInfo-CodeView)
-target_compile_options(lib-DebugInfo-CodeView PRIVATE
- -Wno-everything
-)
-target_include_directories(lib-DebugInfo-CodeView PRIVATE
- ${CMAKE_SOURCE_DIR}/contrib/libs/llvm12/lib/DebugInfo/CodeView
-)
-target_link_libraries(lib-DebugInfo-CodeView PUBLIC
- contrib-libs-cxxsupp
- contrib-libs-llvm12
- lib-DebugInfo-MSF
- llvm12-lib-Support
-)
-target_sources(lib-DebugInfo-CodeView PRIVATE
- ${CMAKE_SOURCE_DIR}/contrib/libs/llvm12/lib/DebugInfo/CodeView/AppendingTypeTableBuilder.cpp
- ${CMAKE_SOURCE_DIR}/contrib/libs/llvm12/lib/DebugInfo/CodeView/CVSymbolVisitor.cpp
- ${CMAKE_SOURCE_DIR}/contrib/libs/llvm12/lib/DebugInfo/CodeView/CVTypeVisitor.cpp
- ${CMAKE_SOURCE_DIR}/contrib/libs/llvm12/lib/DebugInfo/CodeView/CodeViewError.cpp
- ${CMAKE_SOURCE_DIR}/contrib/libs/llvm12/lib/DebugInfo/CodeView/CodeViewRecordIO.cpp
- ${CMAKE_SOURCE_DIR}/contrib/libs/llvm12/lib/DebugInfo/CodeView/ContinuationRecordBuilder.cpp
- ${CMAKE_SOURCE_DIR}/contrib/libs/llvm12/lib/DebugInfo/CodeView/DebugChecksumsSubsection.cpp
- ${CMAKE_SOURCE_DIR}/contrib/libs/llvm12/lib/DebugInfo/CodeView/DebugCrossExSubsection.cpp
- ${CMAKE_SOURCE_DIR}/contrib/libs/llvm12/lib/DebugInfo/CodeView/DebugCrossImpSubsection.cpp
- ${CMAKE_SOURCE_DIR}/contrib/libs/llvm12/lib/DebugInfo/CodeView/DebugFrameDataSubsection.cpp
- ${CMAKE_SOURCE_DIR}/contrib/libs/llvm12/lib/DebugInfo/CodeView/DebugInlineeLinesSubsection.cpp
- ${CMAKE_SOURCE_DIR}/contrib/libs/llvm12/lib/DebugInfo/CodeView/DebugLinesSubsection.cpp
- ${CMAKE_SOURCE_DIR}/contrib/libs/llvm12/lib/DebugInfo/CodeView/DebugStringTableSubsection.cpp
- ${CMAKE_SOURCE_DIR}/contrib/libs/llvm12/lib/DebugInfo/CodeView/DebugSubsection.cpp
- ${CMAKE_SOURCE_DIR}/contrib/libs/llvm12/lib/DebugInfo/CodeView/DebugSubsectionRecord.cpp
- ${CMAKE_SOURCE_DIR}/contrib/libs/llvm12/lib/DebugInfo/CodeView/DebugSubsectionVisitor.cpp
- ${CMAKE_SOURCE_DIR}/contrib/libs/llvm12/lib/DebugInfo/CodeView/DebugSymbolRVASubsection.cpp
- ${CMAKE_SOURCE_DIR}/contrib/libs/llvm12/lib/DebugInfo/CodeView/DebugSymbolsSubsection.cpp
- ${CMAKE_SOURCE_DIR}/contrib/libs/llvm12/lib/DebugInfo/CodeView/EnumTables.cpp
- ${CMAKE_SOURCE_DIR}/contrib/libs/llvm12/lib/DebugInfo/CodeView/Formatters.cpp
- ${CMAKE_SOURCE_DIR}/contrib/libs/llvm12/lib/DebugInfo/CodeView/GlobalTypeTableBuilder.cpp
- ${CMAKE_SOURCE_DIR}/contrib/libs/llvm12/lib/DebugInfo/CodeView/LazyRandomTypeCollection.cpp
- ${CMAKE_SOURCE_DIR}/contrib/libs/llvm12/lib/DebugInfo/CodeView/Line.cpp
- ${CMAKE_SOURCE_DIR}/contrib/libs/llvm12/lib/DebugInfo/CodeView/MergingTypeTableBuilder.cpp
- ${CMAKE_SOURCE_DIR}/contrib/libs/llvm12/lib/DebugInfo/CodeView/RecordName.cpp
- ${CMAKE_SOURCE_DIR}/contrib/libs/llvm12/lib/DebugInfo/CodeView/RecordSerialization.cpp
- ${CMAKE_SOURCE_DIR}/contrib/libs/llvm12/lib/DebugInfo/CodeView/SimpleTypeSerializer.cpp
- ${CMAKE_SOURCE_DIR}/contrib/libs/llvm12/lib/DebugInfo/CodeView/StringsAndChecksums.cpp
- ${CMAKE_SOURCE_DIR}/contrib/libs/llvm12/lib/DebugInfo/CodeView/SymbolDumper.cpp
- ${CMAKE_SOURCE_DIR}/contrib/libs/llvm12/lib/DebugInfo/CodeView/SymbolRecordHelpers.cpp
- ${CMAKE_SOURCE_DIR}/contrib/libs/llvm12/lib/DebugInfo/CodeView/SymbolRecordMapping.cpp
- ${CMAKE_SOURCE_DIR}/contrib/libs/llvm12/lib/DebugInfo/CodeView/SymbolSerializer.cpp
- ${CMAKE_SOURCE_DIR}/contrib/libs/llvm12/lib/DebugInfo/CodeView/TypeDumpVisitor.cpp
- ${CMAKE_SOURCE_DIR}/contrib/libs/llvm12/lib/DebugInfo/CodeView/TypeHashing.cpp
- ${CMAKE_SOURCE_DIR}/contrib/libs/llvm12/lib/DebugInfo/CodeView/TypeIndex.cpp
- ${CMAKE_SOURCE_DIR}/contrib/libs/llvm12/lib/DebugInfo/CodeView/TypeIndexDiscovery.cpp
- ${CMAKE_SOURCE_DIR}/contrib/libs/llvm12/lib/DebugInfo/CodeView/TypeRecordHelpers.cpp
- ${CMAKE_SOURCE_DIR}/contrib/libs/llvm12/lib/DebugInfo/CodeView/TypeRecordMapping.cpp
- ${CMAKE_SOURCE_DIR}/contrib/libs/llvm12/lib/DebugInfo/CodeView/TypeStreamMerger.cpp
- ${CMAKE_SOURCE_DIR}/contrib/libs/llvm12/lib/DebugInfo/CodeView/TypeTableCollection.cpp
-)
+if (CMAKE_SYSTEM_PROCESSOR STREQUAL "aarch64" AND UNIX AND NOT APPLE AND NOT ANDROID)
+ include(CMakeLists.linux-aarch64.txt)
+elseif (APPLE)
+ include(CMakeLists.darwin.txt)
+elseif (CMAKE_SYSTEM_PROCESSOR STREQUAL "x86_64" AND UNIX AND NOT APPLE AND NOT ANDROID)
+ include(CMakeLists.linux.txt)
+endif()