aboutsummaryrefslogtreecommitdiffstats
path: root/contrib/libs/libevent/CMakeLists.txt
diff options
context:
space:
mode:
authorthegeorg <thegeorg@yandex-team.com>2022-12-15 19:25:15 +0300
committerthegeorg <thegeorg@yandex-team.com>2022-12-15 19:25:15 +0300
commit0c31d97afd7858af5f8f858c8addf91655ca9ccc (patch)
tree4d8a246db168f7beaafcd06d486c034115c2123d /contrib/libs/libevent/CMakeLists.txt
parentd1d5f5e00df0dd6efc00880dd8283477fc643aaf (diff)
downloadydb-0c31d97afd7858af5f8f858c8addf91655ca9ccc.tar.gz
Sync linux-headers instead of using system ones
Diffstat (limited to 'contrib/libs/libevent/CMakeLists.txt')
-rw-r--r--contrib/libs/libevent/CMakeLists.txt22
1 files changed, 7 insertions, 15 deletions
diff --git a/contrib/libs/libevent/CMakeLists.txt b/contrib/libs/libevent/CMakeLists.txt
index 1090ce426d..3e0811fb22 100644
--- a/contrib/libs/libevent/CMakeLists.txt
+++ b/contrib/libs/libevent/CMakeLists.txt
@@ -6,18 +6,10 @@
# original buildsystem will not be accepted.
-add_subdirectory(event_core)
-add_subdirectory(event_extra)
-add_subdirectory(event_openssl)
-add_subdirectory(event_thread)
-
-add_library(contrib-libs-libevent INTERFACE)
-target_include_directories(contrib-libs-libevent INTERFACE
- ${CMAKE_SOURCE_DIR}/contrib/libs/libevent/include
-)
-target_link_libraries(contrib-libs-libevent INTERFACE
- libs-libevent-event_core
- libs-libevent-event_extra
- libs-libevent-event_openssl
- libs-libevent-event_thread
-)
+if (CMAKE_SYSTEM_PROCESSOR STREQUAL "aarch64" AND UNIX AND NOT APPLE AND NOT ANDROID)
+ include(CMakeLists.linux-aarch64.txt)
+elseif (APPLE)
+ include(CMakeLists.darwin.txt)
+elseif (CMAKE_SYSTEM_PROCESSOR STREQUAL "x86_64" AND UNIX AND NOT APPLE AND NOT ANDROID)
+ include(CMakeLists.linux.txt)
+endif()