aboutsummaryrefslogtreecommitdiffstats
path: root/contrib/libs/icu/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexSm <alex@ydb.tech>2024-02-16 17:36:07 +0100
committerGitHub <noreply@github.com>2024-02-16 17:36:07 +0100
commit6d3e410c4573ea9dca15ff7076cc9ab528f3c927 (patch)
tree9475a324a167de9bb2b7531a4a4102210436dc01 /contrib/libs/icu/CMakeLists.txt
parent0491f751bf7179304be521251056d3cf10a88da2 (diff)
downloadydb-6d3e410c4573ea9dca15ff7076cc9ab528f3c927.tar.gz
Remove CMakeLists from main (#2032)
Diffstat (limited to 'contrib/libs/icu/CMakeLists.txt')
-rw-r--r--contrib/libs/icu/CMakeLists.txt19
1 files changed, 0 insertions, 19 deletions
diff --git a/contrib/libs/icu/CMakeLists.txt b/contrib/libs/icu/CMakeLists.txt
deleted file mode 100644
index d863ebd180..0000000000
--- a/contrib/libs/icu/CMakeLists.txt
+++ /dev/null
@@ -1,19 +0,0 @@
-
-# This file was generated by the build system used internally in the Yandex monorepo.
-# Only simple modifications are allowed (adding source-files to targets, adding simple properties
-# like target_include_directories). These modifications will be ported to original
-# ya.make files by maintainers. Any complex modifications which can't be ported back to the
-# original buildsystem will not be accepted.
-
-
-if (CMAKE_SYSTEM_NAME STREQUAL "Linux" AND CMAKE_SYSTEM_PROCESSOR STREQUAL "x86_64" AND NOT HAVE_CUDA)
- include(CMakeLists.linux-x86_64.txt)
-elseif (CMAKE_SYSTEM_NAME STREQUAL "Linux" AND CMAKE_SYSTEM_PROCESSOR STREQUAL "aarch64" AND NOT HAVE_CUDA)
- include(CMakeLists.linux-aarch64.txt)
-elseif (CMAKE_SYSTEM_NAME STREQUAL "Darwin" AND CMAKE_SYSTEM_PROCESSOR STREQUAL "x86_64")
- include(CMakeLists.darwin-x86_64.txt)
-elseif (CMAKE_SYSTEM_NAME STREQUAL "Darwin" AND CMAKE_SYSTEM_PROCESSOR STREQUAL "arm64")
- include(CMakeLists.darwin-arm64.txt)
-elseif (WIN32 AND CMAKE_SYSTEM_PROCESSOR STREQUAL "AMD64" AND NOT HAVE_CUDA)
- include(CMakeLists.windows-x86_64.txt)
-endif()