aboutsummaryrefslogtreecommitdiffstats
path: root/contrib/libs/cxxsupp/builtins/CMakeLists.txt
diff options
context:
space:
mode:
authorthegeorg <thegeorg@yandex-team.com>2023-11-03 12:41:08 +0300
committerthegeorg <thegeorg@yandex-team.com>2023-11-03 13:09:53 +0300
commit56b80b3a36ea713d11c31a9c898f5d7e43c84d23 (patch)
tree4d8c0692fad1cee0d8478bcce88456182bf1409e /contrib/libs/cxxsupp/builtins/CMakeLists.txt
parenta020d3047031674dacf4fb87fbbbf82df29fe152 (diff)
downloadydb-56b80b3a36ea713d11c31a9c898f5d7e43c84d23.tar.gz
Default to clang-cl when targeting Windows
As announced [in Atushka](https://clubs.at.yandex-team.ru/arcadia/29556).
Diffstat (limited to 'contrib/libs/cxxsupp/builtins/CMakeLists.txt')
-rw-r--r--contrib/libs/cxxsupp/builtins/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/contrib/libs/cxxsupp/builtins/CMakeLists.txt b/contrib/libs/cxxsupp/builtins/CMakeLists.txt
index 606ff46b4b..f8b31df0c1 100644
--- a/contrib/libs/cxxsupp/builtins/CMakeLists.txt
+++ b/contrib/libs/cxxsupp/builtins/CMakeLists.txt
@@ -10,6 +10,8 @@ if (CMAKE_SYSTEM_NAME STREQUAL "Linux" AND CMAKE_SYSTEM_PROCESSOR STREQUAL "aarc
include(CMakeLists.linux-aarch64.txt)
elseif (CMAKE_SYSTEM_NAME STREQUAL "Darwin" AND CMAKE_SYSTEM_PROCESSOR STREQUAL "x86_64")
include(CMakeLists.darwin-x86_64.txt)
+elseif (WIN32 AND CMAKE_SYSTEM_PROCESSOR STREQUAL "AMD64" AND NOT HAVE_CUDA)
+ include(CMakeLists.windows-x86_64.txt)
elseif (CMAKE_SYSTEM_NAME STREQUAL "Linux" AND CMAKE_SYSTEM_PROCESSOR STREQUAL "x86_64" AND NOT HAVE_CUDA)
include(CMakeLists.linux-x86_64.txt)
endif()