aboutsummaryrefslogtreecommitdiffstats
path: root/certs/CMakeLists.txt
diff options
context:
space:
mode:
authorthegeorg <thegeorg@yandex-team.com>2022-12-15 19:25:15 +0300
committerthegeorg <thegeorg@yandex-team.com>2022-12-15 19:25:15 +0300
commit0c31d97afd7858af5f8f858c8addf91655ca9ccc (patch)
tree4d8a246db168f7beaafcd06d486c034115c2123d /certs/CMakeLists.txt
parentd1d5f5e00df0dd6efc00880dd8283477fc643aaf (diff)
downloadydb-0c31d97afd7858af5f8f858c8addf91655ca9ccc.tar.gz
Sync linux-headers instead of using system ones
Diffstat (limited to 'certs/CMakeLists.txt')
-rw-r--r--certs/CMakeLists.txt31
1 files changed, 7 insertions, 24 deletions
diff --git a/certs/CMakeLists.txt b/certs/CMakeLists.txt
index 299a37ddfe..3e0811fb22 100644
--- a/certs/CMakeLists.txt
+++ b/certs/CMakeLists.txt
@@ -6,27 +6,10 @@
# original buildsystem will not be accepted.
-
-add_library(certs INTERFACE)
-target_link_libraries(certs INTERFACE
- contrib-libs-cxxsupp
- yutil
- library-cpp-resource
-)
-
-add_global_library_for(certs.global certs)
-target_link_libraries(certs.global PUBLIC
- contrib-libs-cxxsupp
- yutil
- library-cpp-resource
-)
-target_sources(certs.global PRIVATE
- ${CMAKE_BINARY_DIR}/certs/b03c08f91a00a60ac9d7daef45f3075a.cpp
-)
-resources(certs.global
- ${CMAKE_BINARY_DIR}/certs/b03c08f91a00a60ac9d7daef45f3075a.cpp
- INPUTS
- ${CMAKE_SOURCE_DIR}/certs/cacert.pem
- KEYS
- /builtin/cacert
-)
+if (CMAKE_SYSTEM_PROCESSOR STREQUAL "aarch64" AND UNIX AND NOT APPLE AND NOT ANDROID)
+ include(CMakeLists.linux-aarch64.txt)
+elseif (APPLE)
+ include(CMakeLists.darwin.txt)
+elseif (CMAKE_SYSTEM_PROCESSOR STREQUAL "x86_64" AND UNIX AND NOT APPLE AND NOT ANDROID)
+ include(CMakeLists.linux.txt)
+endif()