aboutsummaryrefslogtreecommitdiffstats
path: root/nihav-mpeg/Cargo.toml
diff options
context:
space:
mode:
authorKostya Shishkov <kostya.shishkov@gmail.com>2021-11-09 18:30:05 +0100
committerKostya Shishkov <kostya.shishkov@gmail.com>2021-11-09 18:49:28 +0100
commit16cca4d3a7a7505ae31a7469b3547c52650fd194 (patch)
tree4ccafc6255d3e4b341a75f22bc34e4e1e6f6b204 /nihav-mpeg/Cargo.toml
parent576cd7d337fc80ec25bb1fc07fa2d25c5373f7b0 (diff)
downloadnihav-16cca4d3a7a7505ae31a7469b3547c52650fd194.tar.gz
add nihav-mpeg crate
Diffstat (limited to 'nihav-mpeg/Cargo.toml')
-rw-r--r--nihav-mpeg/Cargo.toml27
1 files changed, 27 insertions, 0 deletions
diff --git a/nihav-mpeg/Cargo.toml b/nihav-mpeg/Cargo.toml
new file mode 100644
index 0000000..0b21444
--- /dev/null
+++ b/nihav-mpeg/Cargo.toml
@@ -0,0 +1,27 @@
+[package]
+name = "nihav_mpeg"
+version = "0.1.0"
+authors = ["Kostya Shishkov <kostya.shishkov@gmail.com>"]
+edition = "2018"
+
+[dependencies.nihav_core]
+path = "../nihav-core"
+
+[dependencies.nihav_codec_support]
+path = "../nihav-codec-support"
+features = ["qmf"]
+
+[dev-dependencies]
+nihav_flash = { path = "../nihav-flash", default-features=false, features = ["all_demuxers"] }
+nihav_realmedia = { path = "../nihav-realmedia", default-features=false, features = ["all_demuxers"] }
+
+[features]
+default = ["all_decoders"]
+decoders = []
+
+all_decoders = ["all_video_decoders", "all_audio_decoders"]
+
+all_video_decoders = []
+
+all_audio_decoders = ["decoder_mpa"]
+decoder_mpa = ["decoders"]