summaryrefslogtreecommitdiffstats
path: root/sndplay/Cargo.toml
diff options
context:
space:
mode:
authorKostya Shishkov <kostya.shishkov@gmail.com>2021-04-05 18:11:46 +0200
committerKostya Shishkov <kostya.shishkov@gmail.com>2021-04-05 18:32:13 +0200
commit41e41352fa239e4cbaf355b91a685fc99bef573f (patch)
treee99d50bce2c80eb8bbc2590e95491357deaf136c /sndplay/Cargo.toml
parent3f9b450c63b8876a2925268f08ad34c97a0bc16d (diff)
downloadnihav-player-41e41352fa239e4cbaf355b91a685fc99bef573f.tar.gz
sndplay: use custom decoder crates configuration
Diffstat (limited to 'sndplay/Cargo.toml')
-rw-r--r--sndplay/Cargo.toml13
1 files changed, 12 insertions, 1 deletions
diff --git a/sndplay/Cargo.toml b/sndplay/Cargo.toml
index 3412441..1661282 100644
--- a/sndplay/Cargo.toml
+++ b/sndplay/Cargo.toml
@@ -7,6 +7,17 @@ edition = "2018"
[dependencies]
nihav_core = { path="../../nihav-core" }
nihav_registry = { path="../../nihav-registry" }
-nihav_allstuff = { path="../../nihav-allstuff" }
+nihav_commonfmt = { path="../../nihav-commonfmt", default-features=false, features = ["all_demuxers", "all_audio_decoders"] }
+nihav_duck = { path = "../../nihav-duck", default-features=false, features = ["all_audio_decoders"] }
+nihav_game = { path = "../../nihav-game", default-features=false, features = ["all_demuxers", "all_audio_decoders"] }
+nihav_indeo = { path = "../../nihav-indeo", default-features=false, features = ["all_audio_decoders"] }
+#nihav_itu = { path = "../../nihav-itu" }
+nihav_llaudio = { path = "../../nihav-llaudio" }
+nihav_ms = { path = "../../nihav-ms", default-features=false, features = ["all_audio_decoders"] }
+nihav_qt = { path = "../../nihav-qt", default-features=false, features = ["all_audio_decoders"] }
+nihav_rad = { path = "../../nihav-rad", default-features=false, features = ["all_demuxers", "all_audio_decoders"] }
+nihav_realmedia = { path = "../../nihav-realmedia", default-features=false, features = ["all_demuxers", "all_audio_decoders"] }
+nihav_vivo = { path = "../../nihav-vivo", default-features=false, features = ["all_demuxers", "all_audio_decoders"] }
+
libc = "^0.2"
sdl2-sys = "^0.34"