aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniil Cherednik <dan.cherednik@gmail.com>2018-11-03 00:25:30 +0300
committerDaniil Cherednik <dan.cherednik@gmail.com>2018-11-03 00:32:39 +0300
commitf91a13ba50ea7645b59eea632f6d0ff541800674 (patch)
tree3e86c8a9df8e1f0beba2192f32daa23361ace680 /CMakeLists.txt
parentea08660cc9e28a44a1512a5a56f85e7258d9832d (diff)
downloadlibgha-f91a13ba50ea7645b59eea632f6d0ff541800674.tar.gz
Add function to extract analysed harmonic from given pcm
Added dtmf analysation example
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7c89989..bd3c530 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -42,6 +42,15 @@ target_include_directories(
)
target_link_libraries(main gha m)
+add_executable(dtmf test/dtmf.c)
+target_include_directories(
+ dtmf
+ PRIVATE
+ .
+)
+target_link_libraries(dtmf gha m)
+
+
enable_testing()
add_test(gha_test_simple_1000_0_a main ../test/data/1000hz_0.85.pcm 0 1024 0.14247585 0.0000 0.850000)
add_test(gha_test_simple_1000_0_b main ../test/data/1000hz_0.85.pcm 0 1000 0.14247585 0.0000 0.850000)
@@ -56,3 +65,5 @@ add_test(gha_test_simple_20000_0_a main ../test/data/20000hz_0.85.pcm 0 1024 2.8
add_test(gha_test_simple_20000_0_b main ../test/data/20000hz_0.85.pcm 0 500 2.8495171 0.0000 0.850000)
add_test(gha_test_simple_20000_0_c main ../test/data/20000hz_0.85.pcm 0 128 2.8495171 0.0000 0.850000)
add_test(gha_test_simple_20000_0_d main ../test/data/20000hz_0.85.pcm 0 64 2.8495171 0.0000 0.850000)
+
+add_test(gha_test_dtmf_1 dtmf ../test/data/dtmf.pcm 32 256 0.547416 0.201057 0.949511 0.200154)