aboutsummaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniil Cherednik <dan.cherednik@gmail.com>2020-03-27 00:37:29 +0300
committerDaniil Cherednik <dan.cherednik@gmail.com>2020-03-27 00:37:29 +0300
commit3a8442c829e0c6bb81c1bb6588002f6f1fae109c (patch)
treef59e6b10d4ad764c636a16eda43883e2ca94ad06 /src/CMakeLists.txt
parente16e9c60a18e4b914f5cb16463ed781f09808a25 (diff)
downloadatracdenc-3a8442c829e0c6bb81c1bb6588002f6f1fae109c.tar.gz
Fix project compilation
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 689224e..294050b 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -80,9 +80,10 @@ add_library(pcm_io STATIC ${SOURCE_PCM_IO_LIB})
add_library(oma STATIC ${SOURCE_OMA_LIB})
add_library(bitstream STATIC ${SOURCE_BITSTREAM_LIB})
add_library(atracdenc_impl STATIC ${SOURCE_ATRACDENC_IMPL})
+target_link_libraries(atracdenc_impl fft_impl pcm_io oma bitstream ${SNDFILE_LIBRARIES})
set(SOURCE_EXE
main.cpp
)
add_executable(atracdenc ${SOURCE_EXE})
-target_link_libraries(atracdenc fft_impl pcm_io oma bitstream atracdenc_impl ${SNDFILE_LIBRARIES})
+target_link_libraries(atracdenc pcm_io oma atracdenc_impl ${SNDFILE_LIBRARIES})