aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniil Cherednik <dan.cherednik@gmail.com>2024-07-08 21:42:48 +0000
committerDaniil Cherednik <dan.cherednik@gmail.com>2024-07-09 23:07:40 +0200
commitc4b19af8391640f143aaf446658354dcf01432d1 (patch)
tree68ebb11f38eaec53e16879e59ce776bd249d8491 /CMakeLists.txt
parentf8eabde1e1a2fa6bdb2b09dcdee5cecb750beb30 (diff)
downloadatracdenc-c4b19af8391640f143aaf446658354dcf01432d1.tar.gz
Allow to configure atracdenc to use float instead of double
The default is double for hystorical reason. Actually no any reason to use double precision float point calculation for all processing. AT3P encoding will use float except places were we really need double precision. So this default will be changed to float in near future and this option will be removed.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 81d7999..0332f19 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2,6 +2,9 @@ CMAKE_MINIMUM_REQUIRED(VERSION 3.1)
project(atracdenc)
include_directories(src)
+
+option(ATDE_USE_FLOAT "use float32 precision for dsp" OFF)
+
if (UNIX)
find_package(GTest)
if (GTest_FOUND)