From 0c31d97afd7858af5f8f858c8addf91655ca9ccc Mon Sep 17 00:00:00 2001
From: thegeorg <thegeorg@yandex-team.com>
Date: Thu, 15 Dec 2022 19:25:15 +0300
Subject: Sync linux-headers instead of using system ones

---
 library/cpp/streams/zstd/CMakeLists.txt | 17 +++++++----------
 1 file changed, 7 insertions(+), 10 deletions(-)

(limited to 'library/cpp/streams/zstd/CMakeLists.txt')

diff --git a/library/cpp/streams/zstd/CMakeLists.txt b/library/cpp/streams/zstd/CMakeLists.txt
index 97734ca70f..3e0811fb22 100644
--- a/library/cpp/streams/zstd/CMakeLists.txt
+++ b/library/cpp/streams/zstd/CMakeLists.txt
@@ -6,13 +6,10 @@
 # original buildsystem will not be accepted.
 
 
-
-add_library(cpp-streams-zstd)
-target_link_libraries(cpp-streams-zstd PUBLIC
-  contrib-libs-cxxsupp
-  yutil
-  contrib-libs-zstd
-)
-target_sources(cpp-streams-zstd PRIVATE
-  ${CMAKE_SOURCE_DIR}/library/cpp/streams/zstd/zstd.cpp
-)
+if (CMAKE_SYSTEM_PROCESSOR STREQUAL "aarch64" AND UNIX AND NOT APPLE AND NOT ANDROID)
+  include(CMakeLists.linux-aarch64.txt)
+elseif (APPLE)
+  include(CMakeLists.darwin.txt)
+elseif (CMAKE_SYSTEM_PROCESSOR STREQUAL "x86_64" AND UNIX AND NOT APPLE AND NOT ANDROID)
+  include(CMakeLists.linux.txt)
+endif()
-- 
cgit v1.2.3