aboutsummaryrefslogtreecommitdiffstats
path: root/ydb/public/lib/operation_id/CMakeLists.txt
diff options
context:
space:
mode:
authorthegeorg <thegeorg@yandex-team.com>2022-12-15 19:25:15 +0300
committerthegeorg <thegeorg@yandex-team.com>2022-12-15 19:25:15 +0300
commit0c31d97afd7858af5f8f858c8addf91655ca9ccc (patch)
tree4d8a246db168f7beaafcd06d486c034115c2123d /ydb/public/lib/operation_id/CMakeLists.txt
parentd1d5f5e00df0dd6efc00880dd8283477fc643aaf (diff)
downloadydb-0c31d97afd7858af5f8f858c8addf91655ca9ccc.tar.gz
Sync linux-headers instead of using system ones
Diffstat (limited to 'ydb/public/lib/operation_id/CMakeLists.txt')
-rw-r--r--ydb/public/lib/operation_id/CMakeLists.txt22
1 files changed, 7 insertions, 15 deletions
diff --git a/ydb/public/lib/operation_id/CMakeLists.txt b/ydb/public/lib/operation_id/CMakeLists.txt
index f1618439af..3e0811fb22 100644
--- a/ydb/public/lib/operation_id/CMakeLists.txt
+++ b/ydb/public/lib/operation_id/CMakeLists.txt
@@ -6,18 +6,10 @@
# original buildsystem will not be accepted.
-add_subdirectory(protos)
-add_subdirectory(ut)
-
-add_library(public-lib-operation_id)
-target_link_libraries(public-lib-operation_id PUBLIC
- contrib-libs-cxxsupp
- yutil
- contrib-libs-protobuf
- library-cpp-cgiparam
- library-cpp-uri
- lib-operation_id-protos
-)
-target_sources(public-lib-operation_id PRIVATE
- ${CMAKE_SOURCE_DIR}/ydb/public/lib/operation_id/operation_id.cpp
-)
+if (CMAKE_SYSTEM_PROCESSOR STREQUAL "aarch64" AND UNIX AND NOT APPLE AND NOT ANDROID)
+ include(CMakeLists.linux-aarch64.txt)
+elseif (APPLE)
+ include(CMakeLists.darwin.txt)
+elseif (CMAKE_SYSTEM_PROCESSOR STREQUAL "x86_64" AND UNIX AND NOT APPLE AND NOT ANDROID)
+ include(CMakeLists.linux.txt)
+endif()