aboutsummaryrefslogtreecommitdiffstats
path: root/library/cpp/threading/CMakeLists.txt
diff options
context:
space:
mode:
authormax42 <max42@yandex-team.com>2023-07-29 00:02:16 +0300
committermax42 <max42@yandex-team.com>2023-07-29 00:02:16 +0300
commit73b89de71748a21e102d27b9f3ed1bf658766cb5 (patch)
tree188bbd2d622fa91cdcbb1b6d6d77fbc84a0646f5 /library/cpp/threading/CMakeLists.txt
parent528e321bcc2a2b67b53aeba58c3bd88305a141ee (diff)
downloadydb-73b89de71748a21e102d27b9f3ed1bf658766cb5.tar.gz
YT-19210: expose YQL shared library for YT.
After this, a new target libyqlplugin.so appears. in open-source cmake build. Diff in open-source YDB repo looks like the following: https://paste.yandex-team.ru/f302bdb4-7ef2-4362-91c7-6ca45f329264
Diffstat (limited to 'library/cpp/threading/CMakeLists.txt')
-rw-r--r--library/cpp/threading/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/library/cpp/threading/CMakeLists.txt b/library/cpp/threading/CMakeLists.txt
index 681ef6b24e..018e72c5cc 100644
--- a/library/cpp/threading/CMakeLists.txt
+++ b/library/cpp/threading/CMakeLists.txt
@@ -7,7 +7,9 @@
add_subdirectory(atomic)
+add_subdirectory(blocking_queue)
add_subdirectory(chunk_queue)
+add_subdirectory(cron)
add_subdirectory(equeue)
add_subdirectory(future)
add_subdirectory(hot_swap)
@@ -17,3 +19,4 @@ add_subdirectory(poor_man_openmp)
add_subdirectory(queue)
add_subdirectory(skip_list)
add_subdirectory(task_scheduler)
+add_subdirectory(thread_local)