aboutsummaryrefslogtreecommitdiffstats
path: root/library/cpp/monlib/encode/json/CMakeLists.txt
diff options
context:
space:
mode:
authorarcadia-devtools <arcadia-devtools@yandex-team.ru>2022-02-18 15:49:59 +0300
committerarcadia-devtools <arcadia-devtools@yandex-team.ru>2022-02-18 15:49:59 +0300
commitb4cb34dfb2619f594d82e512fd9ff7fc97400133 (patch)
tree6a64ab25a145265287789bceed3f59e953561206 /library/cpp/monlib/encode/json/CMakeLists.txt
parent5e837a820d5be0671fa4096a1cc1e378453e5132 (diff)
downloadydb-b4cb34dfb2619f594d82e512fd9ff7fc97400133.tar.gz
intermediate changes
ref:1a0585d83f27cb6fb5b9c4f68a08177e10faf3b3
Diffstat (limited to 'library/cpp/monlib/encode/json/CMakeLists.txt')
-rw-r--r--library/cpp/monlib/encode/json/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/library/cpp/monlib/encode/json/CMakeLists.txt b/library/cpp/monlib/encode/json/CMakeLists.txt
new file mode 100644
index 0000000000..697e424fdd
--- /dev/null
+++ b/library/cpp/monlib/encode/json/CMakeLists.txt
@@ -0,0 +1,14 @@
+add_library(monlib-encode-json)
+target_link_libraries(monlib-encode-json PUBLIC
+ contrib-libs-cxxsupp
+ yutil
+ cpp-monlib-encode
+ monlib-encode-buffered
+ cpp-monlib-exception
+ library-cpp-json
+ cpp-json-writer
+)
+target_sources(monlib-encode-json PRIVATE
+ ${CMAKE_SOURCE_DIR}/library/cpp/monlib/encode/json/json_decoder.cpp
+ ${CMAKE_SOURCE_DIR}/library/cpp/monlib/encode/json/json_encoder.cpp
+)