aboutsummaryrefslogtreecommitdiffstats
path: root/library/cpp/lfalloc/CMakeLists.txt
diff options
context:
space:
mode:
authorrobot-ya-builder <robot-ya-builder@yandex-team.com>2022-09-01 05:47:31 +0300
committerrobot-ya-builder <robot-ya-builder@yandex-team.com>2022-09-01 05:47:31 +0300
commite83b936566d59e48df0aa4c414beaf0c4519c772 (patch)
tree43d715760743f81e2060d6ee6f4d4c9d8693751e /library/cpp/lfalloc/CMakeLists.txt
parentfc8096bf8173562afc5da58dbbb019af2ce1ee2f (diff)
downloadydb-e83b936566d59e48df0aa4c414beaf0c4519c772.tar.gz
Update external build system generation utility
* [cmake] Hierarchical add_subdirectroy structure * [cmake] Support for same file compilation multiple times with different flags
Diffstat (limited to 'library/cpp/lfalloc/CMakeLists.txt')
-rw-r--r--library/cpp/lfalloc/CMakeLists.txt17
1 files changed, 5 insertions, 12 deletions
diff --git a/library/cpp/lfalloc/CMakeLists.txt b/library/cpp/lfalloc/CMakeLists.txt
index 9564ed7af0..fc7b1ee73c 100644
--- a/library/cpp/lfalloc/CMakeLists.txt
+++ b/library/cpp/lfalloc/CMakeLists.txt
@@ -6,15 +6,8 @@
# original buildsystem will not be accepted.
-
-add_library(library-cpp-lfalloc)
-target_compile_options(library-cpp-lfalloc PRIVATE
- -Wno-everything
-)
-target_link_libraries(library-cpp-lfalloc PUBLIC
- contrib-libs-cxxsupp
- cpp-malloc-api
-)
-target_sources(library-cpp-lfalloc PRIVATE
- ${CMAKE_SOURCE_DIR}/library/cpp/lfalloc/lf_allocX64.cpp
-)
+if (APPLE)
+ include(CMakeLists.darwin.txt)
+elseif (UNIX AND NOT APPLE)
+ include(CMakeLists.linux.txt)
+endif()