aboutsummaryrefslogtreecommitdiffstats
path: root/library/cpp/http/fetch/CMakeLists.txt
diff options
context:
space:
mode:
authorarcadia-devtools <arcadia-devtools@yandex-team.ru>2022-02-18 15:49:59 +0300
committerarcadia-devtools <arcadia-devtools@yandex-team.ru>2022-02-18 15:49:59 +0300
commitb4cb34dfb2619f594d82e512fd9ff7fc97400133 (patch)
tree6a64ab25a145265287789bceed3f59e953561206 /library/cpp/http/fetch/CMakeLists.txt
parent5e837a820d5be0671fa4096a1cc1e378453e5132 (diff)
downloadydb-b4cb34dfb2619f594d82e512fd9ff7fc97400133.tar.gz
intermediate changes
ref:1a0585d83f27cb6fb5b9c4f68a08177e10faf3b3
Diffstat (limited to 'library/cpp/http/fetch/CMakeLists.txt')
-rw-r--r--library/cpp/http/fetch/CMakeLists.txt32
1 files changed, 32 insertions, 0 deletions
diff --git a/library/cpp/http/fetch/CMakeLists.txt b/library/cpp/http/fetch/CMakeLists.txt
new file mode 100644
index 0000000000..52f844c8d1
--- /dev/null
+++ b/library/cpp/http/fetch/CMakeLists.txt
@@ -0,0 +1,32 @@
+find_package(ZLIB)
+
+add_library(cpp-http-fetch)
+target_link_libraries(cpp-http-fetch PUBLIC
+ contrib-libs-cxxsupp
+ yutil
+ ZLIB::ZLIB
+ library-cpp-charset
+ cpp-digest-md5
+ cpp-http-misc
+ library-cpp-logger
+ cpp-mime-types
+ library-cpp-uri
+ tools-enum_parser-enum_serialization_runtime
+)
+target_sources(cpp-http-fetch PRIVATE
+ ${CMAKE_SOURCE_DIR}/library/cpp/http/fetch/http_digest.cpp
+ ${CMAKE_SOURCE_DIR}/library/cpp/http/fetch/http_socket.cpp
+ ${CMAKE_SOURCE_DIR}/library/cpp/http/fetch/httpheader.cpp
+ ${CMAKE_SOURCE_DIR}/library/cpp/http/fetch/httpload.cpp
+ ${CMAKE_SOURCE_DIR}/library/cpp/http/fetch/exthttpcodes.cpp
+)
+generate_enum_serilization(cpp-http-fetch
+ ${CMAKE_SOURCE_DIR}/library/cpp/http/fetch/httpheader.h
+ INCLUDE_HEADERS
+ library/cpp/http/fetch/httpheader.h
+)
+target_ragel_lexers(cpp-http-fetch
+ PRIVATE
+ ${CMAKE_SOURCE_DIR}/library/cpp/http/fetch/httpfsm.rl6
+ -CF1
+)