aboutsummaryrefslogtreecommitdiffstats
path: root/library/cpp/getopt/CMakeLists.txt
diff options
context:
space:
mode:
authorarcadia-devtools <arcadia-devtools@yandex-team.ru>2022-02-18 15:49:59 +0300
committerarcadia-devtools <arcadia-devtools@yandex-team.ru>2022-02-18 15:49:59 +0300
commitb4cb34dfb2619f594d82e512fd9ff7fc97400133 (patch)
tree6a64ab25a145265287789bceed3f59e953561206 /library/cpp/getopt/CMakeLists.txt
parent5e837a820d5be0671fa4096a1cc1e378453e5132 (diff)
downloadydb-b4cb34dfb2619f594d82e512fd9ff7fc97400133.tar.gz
intermediate changes
ref:1a0585d83f27cb6fb5b9c4f68a08177e10faf3b3
Diffstat (limited to 'library/cpp/getopt/CMakeLists.txt')
-rw-r--r--library/cpp/getopt/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/library/cpp/getopt/CMakeLists.txt b/library/cpp/getopt/CMakeLists.txt
new file mode 100644
index 0000000000..fc9fb0610b
--- /dev/null
+++ b/library/cpp/getopt/CMakeLists.txt
@@ -0,0 +1,13 @@
+add_library(library-cpp-getopt INTERFACE)
+target_link_libraries(library-cpp-getopt INTERFACE
+ contrib-libs-cxxsupp
+ yutil
+ cpp-getopt-small
+ library-cpp-svnversion
+ library-cpp-build_info
+)
+
+add_global_library_for(library-cpp-getopt.global library-cpp-getopt)
+target_sources(library-cpp-getopt.global PRIVATE
+ ${CMAKE_SOURCE_DIR}/library/cpp/getopt/print.cpp
+)