aboutsummaryrefslogtreecommitdiffstats
path: root/library/cpp/codecs/CMakeLists.txt
diff options
context:
space:
mode:
authorthegeorg <thegeorg@yandex-team.com>2022-12-15 19:25:15 +0300
committerthegeorg <thegeorg@yandex-team.com>2022-12-15 19:25:15 +0300
commit0c31d97afd7858af5f8f858c8addf91655ca9ccc (patch)
tree4d8a246db168f7beaafcd06d486c034115c2123d /library/cpp/codecs/CMakeLists.txt
parentd1d5f5e00df0dd6efc00880dd8283477fc643aaf (diff)
downloadydb-0c31d97afd7858af5f8f858c8addf91655ca9ccc.tar.gz
Sync linux-headers instead of using system ones
Diffstat (limited to 'library/cpp/codecs/CMakeLists.txt')
-rw-r--r--library/cpp/codecs/CMakeLists.txt35
1 files changed, 7 insertions, 28 deletions
diff --git a/library/cpp/codecs/CMakeLists.txt b/library/cpp/codecs/CMakeLists.txt
index 776e37d335..3e0811fb22 100644
--- a/library/cpp/codecs/CMakeLists.txt
+++ b/library/cpp/codecs/CMakeLists.txt
@@ -6,31 +6,10 @@
# original buildsystem will not be accepted.
-add_subdirectory(greedy_dict)
-
-add_library(library-cpp-codecs)
-target_link_libraries(library-cpp-codecs PUBLIC
- contrib-libs-cxxsupp
- yutil
- contrib-libs-zstd
- library-cpp-bit_io
- library-cpp-blockcodecs
- cpp-codecs-greedy_dict
- library-cpp-comptable
- cpp-containers-comptrie
- cpp-deprecated-accessors
- library-cpp-packers
- cpp-string_utils-relaxed_escaper
-)
-target_sources(library-cpp-codecs PRIVATE
- ${CMAKE_SOURCE_DIR}/library/cpp/codecs/tls_cache.cpp
- ${CMAKE_SOURCE_DIR}/library/cpp/codecs/codecs.cpp
- ${CMAKE_SOURCE_DIR}/library/cpp/codecs/codecs_registry.cpp
- ${CMAKE_SOURCE_DIR}/library/cpp/codecs/comptable_codec.cpp
- ${CMAKE_SOURCE_DIR}/library/cpp/codecs/delta_codec.cpp
- ${CMAKE_SOURCE_DIR}/library/cpp/codecs/float_huffman.cpp
- ${CMAKE_SOURCE_DIR}/library/cpp/codecs/huffman_codec.cpp
- ${CMAKE_SOURCE_DIR}/library/cpp/codecs/pfor_codec.cpp
- ${CMAKE_SOURCE_DIR}/library/cpp/codecs/solar_codec.cpp
- ${CMAKE_SOURCE_DIR}/library/cpp/codecs/zstd_dict_codec.cpp
-)
+if (CMAKE_SYSTEM_PROCESSOR STREQUAL "aarch64" AND UNIX AND NOT APPLE AND NOT ANDROID)
+ include(CMakeLists.linux-aarch64.txt)
+elseif (APPLE)
+ include(CMakeLists.darwin.txt)
+elseif (CMAKE_SYSTEM_PROCESSOR STREQUAL "x86_64" AND UNIX AND NOT APPLE AND NOT ANDROID)
+ include(CMakeLists.linux.txt)
+endif()