aboutsummaryrefslogtreecommitdiffstats
path: root/library/cpp/blockcodecs/codecs/zstd/CMakeLists.txt
diff options
context:
space:
mode:
authorarcadia-devtools <arcadia-devtools@yandex-team.ru>2022-02-22 16:25:52 +0300
committerarcadia-devtools <arcadia-devtools@yandex-team.ru>2022-02-22 16:25:52 +0300
commitfd6dda9a4b15a851483c803a4fa70bd6bd016598 (patch)
tree32dbfd4b0eb0bd13a0d41e72fedbfc76565f328c /library/cpp/blockcodecs/codecs/zstd/CMakeLists.txt
parenta5ced62af6cd0039f4a228c4db185105d5426e94 (diff)
downloadydb-fd6dda9a4b15a851483c803a4fa70bd6bd016598.tar.gz
intermediate changes
ref:582ed9d2a52706516cc273d3e82d8e3de510b40f
Diffstat (limited to 'library/cpp/blockcodecs/codecs/zstd/CMakeLists.txt')
-rw-r--r--library/cpp/blockcodecs/codecs/zstd/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/library/cpp/blockcodecs/codecs/zstd/CMakeLists.txt b/library/cpp/blockcodecs/codecs/zstd/CMakeLists.txt
index b276eee972..d1864e50e2 100644
--- a/library/cpp/blockcodecs/codecs/zstd/CMakeLists.txt
+++ b/library/cpp/blockcodecs/codecs/zstd/CMakeLists.txt
@@ -7,6 +7,12 @@ target_link_libraries(blockcodecs-codecs-zstd INTERFACE
)
add_global_library_for(blockcodecs-codecs-zstd.global blockcodecs-codecs-zstd)
+target_link_libraries(blockcodecs-codecs-zstd.global INTERFACE
+ contrib-libs-cxxsupp
+ yutil
+ contrib-libs-zstd
+ cpp-blockcodecs-core
+)
target_sources(blockcodecs-codecs-zstd.global PRIVATE
${CMAKE_SOURCE_DIR}/library/cpp/blockcodecs/codecs/zstd/zstd.cpp
)