aboutsummaryrefslogtreecommitdiffstats
path: root/contrib/restricted/patched/replxx/CMakeLists.txt
diff options
context:
space:
mode:
authorMaksim Kita <kitaetoya@gmail.com>2023-08-16 19:45:44 +0300
committermaksim-kita <maksim-kita@yandex-team.com>2023-08-16 21:20:29 +0300
commitb151ead5232fd8b20b940e6686c91b64c700db11 (patch)
treedd94250feffed4aabd4bc889e3db83445da59a99 /contrib/restricted/patched/replxx/CMakeLists.txt
parente4f09ec22e1897b1d7716cd23c5bab9069944cfb (diff)
downloadydb-b151ead5232fd8b20b940e6686c91b64c700db11.tar.gz
Added interactive CLI
Added Interactive CLI Pull Request resolved: #242
Diffstat (limited to 'contrib/restricted/patched/replxx/CMakeLists.txt')
-rw-r--r--contrib/restricted/patched/replxx/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/contrib/restricted/patched/replxx/CMakeLists.txt b/contrib/restricted/patched/replxx/CMakeLists.txt
new file mode 100644
index 0000000000..f8b31df0c1
--- /dev/null
+++ b/contrib/restricted/patched/replxx/CMakeLists.txt
@@ -0,0 +1,17 @@
+
+# This file was generated by the build system used internally in the Yandex monorepo.
+# Only simple modifications are allowed (adding source-files to targets, adding simple properties
+# like target_include_directories). These modifications will be ported to original
+# ya.make files by maintainers. Any complex modifications which can't be ported back to the
+# original buildsystem will not be accepted.
+
+
+if (CMAKE_SYSTEM_NAME STREQUAL "Linux" AND CMAKE_SYSTEM_PROCESSOR STREQUAL "aarch64" AND NOT HAVE_CUDA)
+ include(CMakeLists.linux-aarch64.txt)
+elseif (CMAKE_SYSTEM_NAME STREQUAL "Darwin" AND CMAKE_SYSTEM_PROCESSOR STREQUAL "x86_64")
+ include(CMakeLists.darwin-x86_64.txt)
+elseif (WIN32 AND CMAKE_SYSTEM_PROCESSOR STREQUAL "AMD64" AND NOT HAVE_CUDA)
+ include(CMakeLists.windows-x86_64.txt)
+elseif (CMAKE_SYSTEM_NAME STREQUAL "Linux" AND CMAKE_SYSTEM_PROCESSOR STREQUAL "x86_64" AND NOT HAVE_CUDA)
+ include(CMakeLists.linux-x86_64.txt)
+endif()