aboutsummaryrefslogtreecommitdiffstats
path: root/contrib/restricted/cityhash-1.0.2/CMakeLists.txt
diff options
context:
space:
mode:
authorarcadia-devtools <arcadia-devtools@yandex-team.ru>2022-02-18 15:49:59 +0300
committerarcadia-devtools <arcadia-devtools@yandex-team.ru>2022-02-18 15:49:59 +0300
commitb4cb34dfb2619f594d82e512fd9ff7fc97400133 (patch)
tree6a64ab25a145265287789bceed3f59e953561206 /contrib/restricted/cityhash-1.0.2/CMakeLists.txt
parent5e837a820d5be0671fa4096a1cc1e378453e5132 (diff)
downloadydb-b4cb34dfb2619f594d82e512fd9ff7fc97400133.tar.gz
intermediate changes
ref:1a0585d83f27cb6fb5b9c4f68a08177e10faf3b3
Diffstat (limited to 'contrib/restricted/cityhash-1.0.2/CMakeLists.txt')
-rw-r--r--contrib/restricted/cityhash-1.0.2/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/contrib/restricted/cityhash-1.0.2/CMakeLists.txt b/contrib/restricted/cityhash-1.0.2/CMakeLists.txt
new file mode 100644
index 0000000000..4746074d34
--- /dev/null
+++ b/contrib/restricted/cityhash-1.0.2/CMakeLists.txt
@@ -0,0 +1,13 @@
+add_library(contrib-restricted-cityhash-1.0.2)
+target_include_directories(contrib-restricted-cityhash-1.0.2 PUBLIC
+ ${CMAKE_SOURCE_DIR}/contrib/restricted/cityhash-1.0.2
+)
+target_include_directories(contrib-restricted-cityhash-1.0.2 PRIVATE
+ ${CMAKE_SOURCE_DIR}/contrib/restricted/cityhash-1.0.2
+)
+target_link_libraries(contrib-restricted-cityhash-1.0.2 PUBLIC
+ contrib-libs-cxxsupp
+)
+target_sources(contrib-restricted-cityhash-1.0.2 PRIVATE
+ ${CMAKE_SOURCE_DIR}/contrib/restricted/cityhash-1.0.2/city.cc
+)